The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Linux router и 2-а сетевызх интерфейса."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Linux router и 2-а сетевызх интерфейса."  
Сообщение от vozd on 09-Фев-07, 10:42 
Здравствуйте.
Такая проблема возникла. В машине стоит два сетевых интерфейса в PCI слотах. От одной сетевой кабель идёт в ДСЛ модем (eth0, самая первая по-порядку в PCI слоте), другая - воткнута в свитч (eth1, вторая по-порядку в PCI слоте). Две сетевые карточки рабочие на 100 процентов. Делаем пинг на модем 192.168.1.1 - модем отвечает. Делаем пинг на сеть 10.10.1.2 - машина не отвечает. Когда говоришь ifconfig eth0 down, то втроая начинает пинговать сеть. Говоришь ifconfig eth0 up, то вторая сетевуха по-прежнему пингует сеть, а первая уже не пингует модем.
Принятые пути решения проблемы - загрузка с лив дистрибутива - та же история, смена местами сетевых карт - таже история, поставлены в корпус карты от одного и того же производителя - та же проблема, физика проверена - она рабочая, сами сетевые карты отвечают на пинг, TOP показывает минимальную згрузку без зомби процессов, логи не пишут ничего из раздела warn, error, info по поводу проблем с сетевухами, пробывал останавливать запущенные сервисы - не помогло.
Машина - Pentium MMX,  64М памяти.
Сборка - монолитное ядро под эту машину - 2.4.34.1, драйвера на сетевый карты становятся нормально, по команде ifconfig я их вижу, могу им присвоить ипи и его же пингануть, syslog показывает, что им присвоены разные прерывания - 10, 9, из запущеных сервисов - Postfix, Ssh, Popa3d, NTP.
Варианты решения, которые не испробованы - собрать ядро 2.6.20.
Кто сталкивался с такой проблемой - просьба помочь.
Спасибо.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Linux router и 2-а сетевызх интерфейса."  
Сообщение от ipmanyak (??) on 09-Фев-07, 12:25 
какой линукс и какой версии ?  Это недавно началось или только что поднял сервер?
Покажи  /etc/modules.conf
покажи таблицу роутинга
route -n
после загрузки системы  и после дауна интерфейса
проверь наличие  1 в файле /proc/sys/net/ipv4/ip_forward


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Linux router и 2-а сетевызх интерфейса."  
Сообщение от vozd on 09-Фев-07, 13:34 
>какой линукс и какой версии ?  Это недавно началось или только
>что поднял сервер?
>Покажи  /etc/modules.conf
>покажи таблицу роутинга
>route -n
>после загрузки системы  и после дауна интерфейса
>проверь наличие  1 в файле /proc/sys/net/ipv4/ip_forward

Slackware 11.0, ядро МОНОЛИТНОЕ, никаких модулей. Таблица роутинга простая
192.168.1.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
10.10.1.0      0.0.0.0         255.255.255.0   U     0      0        0 eth1

Сервак только что поднят.
/proc/sys/net/ipv4/ip_forward - 1 стоит. Она стоит и до того, как опускаю сетевой интерфейс и после того, как его поднимаю вновь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру