The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"ALTLinux"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"ALTLinux"  
Сообщение от Fit_Eugene email(ok) on 19-Май-06, 11:12 
Добрый день! Обновил в ALTLinux 2.4 mysql через сизифа, система ругается:
[root@server mnt]# service mysqld restart
/bin/sh: error while loading shared libraries: /usr/lib/libstdc++.so.6: cannot handle TLS data

Подскажите, в чем может быть проблема. Заранее спасибо.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

  • ALTLinux, DiCom, 11:27 , 19-Май-06, (1)  
    • ALTLinux, Fit_Eugene, 12:02 , 19-Май-06, (2)  
      • ALTLinux, DiCom, 12:47 , 19-Май-06, (3)  
        • ALTLinux, Fit_Eugene, 12:51 , 19-Май-06, (4)  
          • ALTLinux, Fit_Eugene, 14:07 , 19-Май-06, (5)  

Сообщения по теме [Сортировка по времени, UBB]


1. "ALTLinux"  
Сообщение от DiCom email on 19-Май-06, 11:27 
Обновите тогда и все остальное...
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "ALTLinux"  
Сообщение от Fit_Eugene email(ok) on 19-Май-06, 12:02 
>Обновите тогда и все остальное...

так он потащил обновлять по депенденсам, и обновил очень многое.

[root@server root]# apt-get install MySQL-server
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  MySQL-client apt aptitude ash bash bc fetchmail ftp hwclock kbdrate kdepim-common lftp libMySQL libXaw libapm
  libapt libdb4.4 libdmx libelf libexpat libfam libgcc4.1 libkrb5 liblua5.1 libreadline librpm librpmbuild
  libsigc++2.0 libstdc++3.3 libstdc++4.1 maildrop-common maildrop-userdb maildrop-utils ntp-aux ntp-doc openssh
  osec perl-DBI perl-DBM perl-Storable perl-base perl-devel php php-libs rpm sessreg setproctitle setxkbmap sh
  syslog-common xconsole xdpyinfo xmessage xmodmap xrdb xsetroot
The following packages will be upgraded
  MySQL-client MySQL-server apt aptitude bash bc fetchmail ftp hwclock kbdrate kdepim-common lftp libMySQL libapm
  libapt libexpat libkrb5 libreadline librpm librpmbuild libstdc++3.3 ntp-aux ntp-doc openssh osec perl-DBI
  perl-DBM perl-Storable perl-base perl-devel php-libs rpm sh syslog-common
The following packages will be REPLACED:
  libgcc3.3 (by libgcc4.1)
The following packages will be REMOVED:
  SysVinit-usermode XFree86 XFree86-cyr_rfx-fonts-cp1251 XFree86-server XFree86-
  agetty anacron apache apache-common apache-mod_perl apmd apt-indicator autolog
  dhcp-common fetchmail-daemon hotplug ifplugd interactivesystem kbdrate-usermod
  kdeartwork-screensavers kdebase kdebase-common kdebase-kcmshell kdebase-kcontr
  kdebase-kio kdebase-kio-samba kdebase-konqueror kdebase-libkonq kdebase-libs k
  kdegraphics-kuickshow kdelibs kdemultimedia-juk kdemultimedia-kaudiocreator kd
  kdemultimedia-kscd kdemultimedia-libs kdenetwork-kget kdenetwork-kopete kdenet
  kdepim-kmail kdepim-knode kdepim-kontact kdepim-korganizer kdepim-ktnef kdepim
  kdeutils-kfloppy kdeutils-kgpg kkbswitch klogd kmail-aegypten-plugins libstdc+
  man-pages man-pages-ru man-pages-uk menu mingetty mkxauth mod_php mod_ssl nfs-
  ntpd ntpdate openssh-clients openssh-server osec-mailreport pam0_console passw
  php-mysql phpMyAdmin popa3d portmap postgresql power powermgmt-base procmail p
  python-modules-bsddb python-modules-compiler python-modules-curses python-modu
  python-modules-hotshot python-modules-logging python-modules-xml python-strict
  stmpclean su sudo synaptic synaptic-usermode sysklogd syslogd sysstat vlock vs
The following NEW packages will be installed:
  ash libXaw libdb4.4 libdmx libelf libfam libgcc4.1 liblua5.1 libsigc++2.0 libs
  maildrop-userdb maildrop-utils php sessreg setproctitle setxkbmap xconsole xdp
  xsetroot
34 upgraded, 23 newly installed, 1 replaced, 123 removed and 244 not upgraded.
Need to get 24.7MB/24.9MB of archives.
After unpacking 214MB disk space will be freed.

а теперь ничего не дает сделать

[root@server root]# apt-get
apt-get: error while loading shared libraries: /usr/lib/libstdc++.so.6: cannot handle TLS data


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "ALTLinux"  
Сообщение от DiCom email on 19-Май-06, 12:47 
>>Обновите тогда и все остальное...
>
>так он потащил обновлять по депенденсам, и обновил очень многое.
>
Естественно, а зачем вы так делали?

http://wiki.sisyphus.ru/changes/Master24?v=15ae

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "ALTLinux"  
Сообщение от Fit_Eugene email(ok) on 19-Май-06, 12:51 
спасибо за ссылку, еще маленький вопрос, чему должна быть равна переменная LD_PRELOAD?
я ее по дурости поменял, не посмотрев


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "ALTLinux"  
Сообщение от Fit_Eugene email(ok) on 19-Май-06, 14:07 
все, вроде более менее оживил. перелил с другого сервака
libstdc++.so.6 вроде mysql заработал, а вот всякие апты ругаются

[root@server /]# apt-get --fix-fixable update
E: Command line option --fix-fixable is not understood
[root@server /]# apt-get --fix-missing update
free(): invalid pointer 0x808d328!
free(): invalid pointer 0x808d468!
0% [Working]free(): invalid pointer 0x8055990!
free(): invalid pointer 0x80559a8!
free(): invalid pointer 0x8054f88!
E: Method cdrom has died unexpectedly!
W: Release files for some repositories could not be retrieved or authenticated.
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object


там еще есть libstdc++.so.6.0.8. может и его следует поменять?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру