The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"проблема с установкой amavisd-new"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"проблема с установкой amavisd-new" 
Сообщение от evgenii Искать по авторуВ закладки(ok) on 15-Ноя-05, 21:34  (MSK)
ОС - FreeBsd 4.8
Хочу прикрутить Amavisd-new к Postfix, перечитал кучу статей по этому поводу. Но везде пишут про установку из исходников, неужели нельзя установить из портов??? Я в шоке.....
Итак я начал установку из портов.
Сначала amavisd ругнулся, что ему нужен Perl 5.8.2 - установил Perl 5.8.7
Теперь ругается, что у меня уже установлены перловые модули и их надо переустановить либо использовать FORCE_PKG_REGISTER. Что за маразм???
Помогите, кто сталкивался или все устанавливали из сорцов?
  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]

1. "проблема с установкой amavisd-new" 
Сообщение от Skif Искать по авторуВ закладки(ok) on 15-Ноя-05, 21:45  (MSK)

>Теперь ругается, что у меня уже установлены перловые модули и их надо
>переустановить либо использовать FORCE_PKG_REGISTER. Что за маразм???
>Помогите, кто сталкивался или все устанавливали из сорцов?

Батенька, это не маразм, это значит, что Makefile не смотрели и несмотрели зависимости. Это раз.
Во-вторых ругается будет не только amavisd, а еще куча других приложений, так что либо руками апдейте модули (deinstall и снова пересборка) либо при сборке обратите внимание на perl-after-upgrade.
Почему ругается? Да потому что со старым модулем ему не понятно уже как работать. Зависимости понимаете ли. Perl хотит новых версий модулей... зависимости в портах тоже. и так все по кругу...

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "проблема с установкой amavisd-new" 
Сообщение от evgenii Искать по авторуВ закладки(??) on 16-Ноя-05, 00:06  (MSK)
>
>>Теперь ругается, что у меня уже установлены перловые модули и их надо
>>переустановить либо использовать FORCE_PKG_REGISTER. Что за маразм???
>>Помогите, кто сталкивался или все устанавливали из сорцов?
>
>Батенька, это не маразм, это значит, что Makefile не смотрели и несмотрели
>зависимости. Это раз.
почему не смотрел - смотрел, видел зависимости, поэтому и решил все установить из портов а не из сорцов руками собирать модули (как везде пишут...)

>Во-вторых ругается будет не только amavisd, а еще куча других приложений, так
>что либо руками апдейте модули (deinstall и снова пересборка)
> либо при сборке обратите внимание на perl-after-upgrade.
>Почему ругается? Да потому что со старым модулем ему не понятно уже
>как работать. Зависимости понимаете ли. Perl хотит новых версий модулей... зависимости
>в портах тоже. и так все по кругу...
почему старый-то??? поставил из портов самый свежий perl-5.8.7

Заодно еще вопрос спрошу: при установке требует libmilter от sendmail? а у меня установлен postfix. Как быть в этом случае?

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "проблема с установкой amavisd-new" 
Сообщение от be emailИскать по авторуВ закладки on 16-Ноя-05, 09:11  (MSK)
vim Makefile.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "проблема с установкой amavisd-new" 
Сообщение от evgenii Искать по авторуВ закладки(ok) on 16-Ноя-05, 09:41  (MSK)
>vim Makefile.
причем тут Makefile
===>  Installing for amavisd-new-2.3.3,1
===>   amavisd-new-2.3.3,1 depends on file: /usr/local/lib/perl5/site_perl/5.8.7/mach/Unix/Syslog.pm - not found
===>    Verifying install for /usr/local/lib/perl5/site_perl/5.8.7/mach/Unix/Syslog.pm in /usr/ports/sysutils/p5-Unix-Syslog
===>  Installing for p5-Unix-Syslog-0.100
===>   p5-Unix-Syslog-0.100 depends on file: /usr/local/bin/perl5.8.7 - found
===>   Generating temporary packing list
===>  Checking if sysutils/p5-Unix-Syslog already installed
===>   p5-Unix-Syslog-0.100 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of sysutils/p5-Unix-Syslog
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/sysutils/p5-Unix-Syslog.
*** Error code 1

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "проблема с установкой amavisd-new" 
Сообщение от kazuss Искать по авторуВ закладки(ok) on 01-Дек-05, 10:09  (MSK)

>
>Stop in /usr/ports/sysutils/p5-Unix-Syslog.
>*** Error code 1
Удали этот порт и при установке amavisd он его по новой установит.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ]




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру