snmptrapd.conf - configuration file for the Net-SNMP trap daemon
The snmptrapd.conf file is the configuration file that defines how the Net-SNMP trap-receiving daemon (snmptrapd(1M)) operates when it receives a trap. These files can contain any of the directives found in the Directives section, below. This file is not required for the daemon to operate, receive, or report traps. It is used solely as a method of providing extensibility to the trap daemon.
There can be multiple snmptrapd.conf files on a single machine.
Before creating or modifying a snmptrapd.conf file, read snmp_config(4). This page describes how the Net-SNMP configuration files work, individually and together, and where they are located.
traphandle OID | default program [args...]
The traphandle configuration directive configures the snmptrapd program to launch an external program any time it receives a trap matching the OID token. If the OID token is the word default, then any trap not matching any other trap handler will call the default one instead. The program is fed details about the trap to its standard input, in the following format, one entry per line:
The name of the host that sent the trap, as determined by gethostbyaddr(3NSL).
The IP address of the host that sent the trap.
A list of variable bindings that describe the trap and the variables enclosed in it. The first token on the line, delimited by a space, is the OID. The remainder of the line is its value. The first OID should be system.sysUpTime.0. The second should be the ...snmpTrap.snmpTrapOID.0 OID. The remaining OIDs, with the possible exception of the last one, are the variable bindings contained within the trap. For SNMPv1 traps, the very last OID will be the ...snmpTrap.snmpTrapEnterprise OID and its value. Essentially, SNMPv1 traps have been converted to the SNMPv2 trap PDU type by the method described in the SNMPv1/SNMPv2/SNMPv3 coexistence document (RFC 2576).
Turns off the support for the NOTIFICATION-LOG-MIB and thus does not retain logged traps. Normally, the snmptrapd program keeps a certain number of traps in memory so that they can be retrieved by querying the nlmLogTable and nlmLogvariableTable tables. See snmptrapd(1M) and the NOTIFICATION-LOG-MIB for details.
createUser username (MD5|SHA) authpassphrase [DES]
See snmpd.conf(4) for a description of how to create SNMPv3 users. The process of creating users is similar to creating users for other SNMP versions. For SNMPv3, the configuration file name changes to snmptrapd.conf from snmpd.conf.
The format used to print a SNMPv1 TRAP message. See snmptrapd(1M) for the layout characters available.
The format used to print a SNMPv2 TRAP2 or INFORM message. Note that the SNMPv3 protocol uses SNMPv2-style TRAPs and INFORMs.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
snmptrapd(1M), syslog(3C), snmpd.conf(4), snmp_variables(4), snmp_config(4), attributes(5), sma_snmp(5)
In the current release, the daemon blocks on the executing traphandle commands. This behavior is subject to change in a future release.
Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру