The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Каталог документации / Раздел "Операционные системы" (Архив | Для печати)

Оптимизация интерфейса GIMP

Автор: Александр Прокудин
Оригинал: linuxgraphics.ru

Внимание, эффективное использование этого материала предполагает наличие в системе GIMP версии 2.3.11 и выше! Дальнейшее развитие материала предполагается в базе знаний.

Визитной карточкой случайных пользователей GIMP стали вот такие скриншоты:

Скриншот с ЛОРа

Что мы видим помимо ужасающей палитры цветов в теме Gtk+? :-)

  1. Кегль в тексте графических элементов интерфейса великоват.
  2. Сами графические элементы великоваты.
  3. Палитре свойств активного инструмента явно не хватает места;
  4. Есть редко используемые палитры и нет часто используемых.

Словом, заметно, что автор скриншота в GIMP работает мало, поэтому не беспокоится по поводу неоптимизированного интерфейса. Что может сделать пользователь, который только что поставил GIMP и при первом же запуске программы получил удар бейсбольной битой по области мозга, отвечающей за эстетическое восприятие действительности?

Кегль текста и размер графических элементов

Уже довольно давно GIMP может использовать разные темы Gtk+. По умолчанию в комплекте есть исходная тема (Default) и "уменьшенная" тема (Small). Ввиду некоторых особенностей библиотеки графических элементов Gtk+, на которой написан GIMP, размеры элементов снижаются, главным образом, за счёт уменьшения кегля шрифта. Плюс к тому, в теме Small используются пиктограммы меньшего размера (16×16 пикселов вместо 22×22). Дополнительно уменьшить сами по себе виджеты возможно, но руки у разработчиков до этого ещё не дошли, хотя некоторый прогресс есть.

Переключение между темами делается через диалог настроек программы. В панели инструментов откройте меню "Файл" и выберите пункт "Настроить...". В появившемся диалоге перейдите на вкладку "Темы", в списке тем щёлкните по теме "Small" и нажмите "ОК". Изменения немедленно вступят в силу.

Но и это ещё не всё. Если внимательно посмотреть в файл gtkrc темы Small, можно без труда найти там строку

# font_name = "sans 8"

Скопируйте каталог /usr/share/gimp/2.0/themes/Small в ~/.gimp-2.3/themes/ и переименуйте его в "even smaller". Теперь в файле ~/.gimp-2.3/themes/even smaller/gtkrc можно написать что-нибудь совершенно возмутительное, например

font_name = "Tahoma 7"

Таким образом вы скажете GIMP использовать означенный шрифт означенного кегля для всех элементов интерфейса. Остаётся выбрать полученную тему в диалоге настройки GIMP и получить диалоги более приемлемого размера.

При желании вы можете создать собственную тему, в которой, например, пиктограммы в панели инструментов будут в оттенках серого (многим мешают цветастые пиктограммы). За основу новой темы стоит взять тему Default.

Оптимизация размера диалоговых окон

Разработчики GIMP чутки к нуждам начинающих пользователей и позаботились о том, чтобы в случае чего прямо из любого диалога можно было вызвать справку по нему. Беда в том, что в некоторых диалогах кнопок хватает и без "Справки". А с ней такие диалоги и вовсе вытягиваются в ширину как панорама с углом обзора в 360╟.

Диалог масштабирования с кнопкой вызова справки

Лечится это очень просто. Откройте диалоге настроек программы, перейдите на вкладку "Система помощи" и уберите флажок с параметра "Показывать кнопку "Справка"".

Диалог масштабирования без кнопки вызова справки

Вы по-прежнему сможете открывать контекстную справку для диалогов, нажимая F1.

Оптимизация палитр

Перепарковка

Любую плавающую палитру/диалог GIMP можно припарковать к другой палитре либо соседней вкладкой, либо начать ею новую группу вкладок внизу или вверху. Давайте потренируемся. Нажмите значок с символом палитры параметров и потащите его к палитре слоёв. Дотащите палитру за пиктограмму чуть правее пиктограммы палитры слоёв и бросьте. Получится следующее:

Диалог параметров активного инструмента

Держать палитру слоёв и палитру параметров активного инструмента в соседних вкладках из соображений удобства - не очень хорошая затея. Лучше бы палитру слоёв сделать отдельной от всех, примерно вот так:

Палитра слоёв, вынесенная из группы справа

Для этого потащите палитру за её пиктограмму и отпустите в свободном пространстве вне группы вкладок.

Если вы используете GIMP для работы с фотографиями, имеет смысл держать под рукой гистограмму активного снимка. В панели инструментов выберите пункт меню "Файл→Диалоги→Гистограмма" и прицепите открывшуюся палитру внизу или вверху стопки палитр справа. Пример проиллюстрирован выше.

Подробнее об управлении диалогами GIMP можно почитать в соответствующем разделе справки по GIMP на русском языке.

Размер областей предпросмотра

По умолчанию в GIMP используются сравнительно большие области просмотра слоёв (палитра "Слои") и совершённых действий (палитра "История действий").

Пример:

Обычный вид палитры слоёв Обычный вид палитры истории действий

С палитрой слоёв справиться проще простого. У каждой палитры GIMP есть своё контекстное меню, вызываемое щелчком второй (правой) клавишей мыши или щелчком по кнопке с символом треугольника вверху справа. В контекстном меню для палитры слоёв перейдите в субменю "Размер предпросмотра" и выберите более подходящий вариант. Если судьба настолько добра к вам, что вы сидите за 21'' монитором, возможно, вы захотите вместо размера поменьше выбрать размер побольше.

Вариант поменьше:

Палитра слоёв с уменьшенной областью предпросмотра

Вариант побольше:

Палитра слоёв с увеличенной областью предпросмотра

Точно так же размер предпросмотра можно поменять для палитры "Каналы". Всё те же изменения можно сделать через диалог настройки программы на вкладке "Интерфейс".

С палитрой истории действий всё немного сложнее: графический интерфейс к смене области предпросмотра разработчики делать отказываются, потому что для этого нужно поменять слишком много в начинке GIMP. Отказываются - ну и ладно. Откройте файл ~/.gimp-2.3/gimprc в текстовом редакторе и добавьте в него параметр

(undo-preview-size large)

Large (большой) - исходное значение, которое уже используется по умолчанию. Вместо него укажите одно из следующих значений: tiny (крошечный), extra-small (очень маленький), small (маленький), medium (средний), extra-large (очень большой), huge (огромный), enormous (просто неприлично большой) или gigantic (гигантский). После сохранения файла перезапустите GIMP для учёта изменений.

Палитра истории действий с уменьшенной областью предпросмотра

Типы поведения окон

В GIMP окна палитр/диалогов могут вести себя по разному. Типы поведений:

  1. Стандартное. Такие окна отображаются в панели задач вместе с окнами прочих программ и управляются стандартным образом: их можно сворачивать, раскрывать обратно и даже разворачивать на полный экран (сложно придумать, кому и для чего это нужно, но факт остаётся фактом) - фантазия ограничивается только возможностями оконного менеджера. Тем не менее, отображение таких окон диалогов можно временно отключить и включить обратно нажатием клавиши Tab.
  2. Вспомогательное. Это новый тип, появившийся в серии версий 2.3.х. Вспомогательное окно не отображается в списке задач. Оно как бы прилипает к каждому окну изображения и путешествует вместе с ним. Отображение вспомогательных окон для активного окна изображения точно так же можно отключить нажатием клавиши Tab. Недостаток этого типа поведения состоит в том, что если вы закрыли последние изображение со временно отключенными диалогами, то чтобы вернуть их, нужно открыть новое изображение через gimp-remote (gimp-remote-2.3 для нестабильной ветки 2.3.х).
  3. Всегда наверху. В этом случае панели и диалоги для окна изображения в стандартном режиме всегда находятся поверх него, даже если окно изображение полностью развёрнуто.

Смена типа поведения окна всегда требует перезапуска GIMP для учёта изменений.

Окна в обычном и полноэкранном режиме

По умолчанию в GIMP полноэкранный режим считается обычным режимом редактирования, поэтому там включены все те же настройки вида, что и для обычного режима, включая цвет фона. Насколько это вам подходит - решайте сами. Добавить недостающее и убрать лишнее для всех последующих сессий работы можно во вкладке "Окно изображения→Внешний вид" диалога настроек GIMP. Скажем, включённые по умолчанию полосы прокрутки - в наше время совершенно излишняя вещь, потому что для быстрого перемещения есть несколько других, субъективно, более удобных способов (см. ниже).

Показ направляющих и сетки в полноэкранном режиме по умолчанию можно отменить и назначить для их показа простые клавиатурные комбинации. Если вы много пользовались Adobe Photoshop, вам покажутся удобными сочетания Ctrl+; и Ctrl+' для направляющих и сетки соответственно. Лично мне показались очень удобными и легко запоминающимися | и # из Inkscape. По ним сразу видно, за что отвечает каждая. Таким образом полноэкранный режим можно из режима просмотра результата быстро превратить в нормальный рабочий режим и наоборот.

Горячие клавиши

По умолчанию в GIMP отключена очень полезная функция, благодаря которой так называемые "горячие клавиши" можно назначить, просто набрав их в нужном пункте меню. Благодаря этой функции можно быстро переназначить существующие и назначить новые клавиатурные комбинации вызова инструментов, фильтров и прочих диалогов, не заходя в диалог настройки клавиатурных комбинаций. Например, можно открыть меню "Цвет", навести курсор на пункт "Уровни..." и нажать Ctrl+L, после чего в этой и всех следующих сеансах работы с GIMP по Ctrl+L можно вызывать диалог уровней.

Обычно эта функция отключается и включается глобально для всех приложений, написанных на Gtk. Но поскольку GIMP использует свои темы Gtk+, только частично наследующие параметры внешних тем, на него это не распространяется. Функцию динамического назначения клавиатурных комбинаций включается на вкладке "Интерфейс" диалога настроек GIMP.

Что ещё можно поменять

Помимо исходных настроек программы сомнение вызывают некоторые другие исходные значения, используемые GIMP и не имеющие отношения к интерфейсу.

Интерполяция

С исходными настройками для многих действий вроде смены размера изображения или коррекции перспективы в GIMP используется линейная интерполяция. До серии версий 2.3.х в GIMP никакой другой не было, а теперь есть и билинейная (среднеквадратичная) и интерполяция Ланцоша. Вторая из них часто вызывает нарекания, потому что изображения, над которыми с нею поработали, "обогащаются" видимыми артефактами. Поскольку алгоритм B-Spline в GIMP пока не реализован, оптимальным выбором будет скорее билинейная интерполяция: после изменения размеров фотографии с её использованием не возникает такого сильного желания пройтись по снимку фильтром нерезкой маски. В качестве исходной билинейная интерполяция устанавливается на вкладке "Параметры инструментов" диалога настроек GIMP.

Значение кэша и уровни отката

Если до выхода версии 2.3.11 вы ни разу не меняли исходные значения кэша и страдали от "тормозов" GIMP (например, ждали минуту-две, пока по быстрой маске на восьмимегапиксельном снимке нарисуется радиальный градиент), самое время навестить вкладку "Окружение" диалога настроек. Укажите значение кэша равным не менее 2 Гбайт и заодно поднимите значения соседних параметров ("Максимально памяти для отката и "Максимальный размер нового изображения") хотя бы до одного гигабайта. Перезапустите GIMP для учёта изменений.

По умолчанию GIMP позволяет откатиться всего лишь на 5 действий и резервирует под это 32 мегабайта памяти. И того, и другого маловато для работы. Стоит увеличить количество отменяемых действий хотя бы до 20 и зарезервировать под них как минимум полгигабайта памяти.

Перемещение по изображению

Устав слушать жалобы пользователей, мигрировавших с продуктов Adobe, разработчики GIMP начиная с версии 2.3.12 (на момент публикации текста готовится к выходу) сделали пробел стандартным переключателем для навигации по изображению, оставив ту же функцию для средней клавиши мыши. Это поведение меняется в диалоге настроек программы на вкладке "Окно изображения". Например, если вас устраивало предыдущее поведение, перейдите на эту вкладку и для параметра "Когда нажат пробел" выберите действие "Переключиться на инструмент перемещения".

Есть ещё несколько способов перемещения по изображению, о которых стоит помнить:

  1. Перетаскивание области просмотра изображения с нажатой средней клавишей мыши.
  2. Комбинация из клавиши Shift и стрелок.
  3. Мини-навигатор по изображению в правом нижнем углу.
  4. Диалог навигации по изображению.

Автор: Александр Прокудин
Лицензия: GNU Free Documentation License, без инвариантных разделов


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor