offsetof - offset of structure member
#include <stddef.h> size_t offsetof(type, member-designator);
The offsetof() macro defined in <stddef.h> expands to an integral constant expression that has type size_t. The value of this expression is the offset in bytes to the structure member (designated by member-designator) from the beginning of its structure (designated by type).
See attributes(5) for descriptions of the following attributes:
Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру