The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ошибки на интерфейсе Catalyst 3750"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Ошибки на интерфейсе Catalyst 3750"  +/
Сообщение от uanic email(ok) on 26-Янв-06, 15:11 
Счётчики Runts очень быстро ростут, лампочка на catalyst мигает жёлтым
цветом.
часть настроек, что по моему мнению относится к проблеме:
------------------------------
...
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id

interface GigabitEthernet1/0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3,17
switchport mode trunk

interface GigabitEthernet1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
...

# show interfaces gigabitEthernet 1/0/13 counters errors

Port        Align-Err    FCS-Err   Xmit-Err    Rcv-Err UnderSize
Gi1/0/13            0          0          0   17247538  34495076

Port      Single-Col Multi-Col  Late-Col Excess-Col Carri-Sen     Runts
Giants
Gi1/0/13           0         0         0          0         0  17247538
0

# show interfaces counters trunk

Port        TrunkFramesTx  TrunkFramesRx  WrongEncap
...
Gi1/0/13        100127338      100622824           0
...
Gi1/0/22        237026205      213296059           0
...

Обьясните почему на этих двух портах счётчики не нулевые, в отличие от
остальных?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ошибки на интерфейсе Catalyst 3750"  +/
Сообщение от Nailer (??) on 26-Янв-06, 15:44 
>Счётчики Runts очень быстро ростут, лампочка на catalyst мигает жёлтым
>цветом.
>часть настроек, что по моему мнению относится к проблеме:
>------------------------------
>...
>spanning-tree mode pvst
>no spanning-tree optimize bpdu transmission
>spanning-tree extend system-id
>
>interface GigabitEthernet1/0/13
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 1-3,17
> switchport mode trunk
>
>interface GigabitEthernet1/0/22
> switchport trunk encapsulation dot1q
> switchport mode trunk
>...
>
># show interfaces gigabitEthernet 1/0/13 counters errors
>
>Port        Align-Err    
>FCS-Err   Xmit-Err    Rcv-Err UnderSize
>Gi1/0/13            
>0          0
>         0  
> 17247538  34495076
>
>Port      Single-Col Multi-Col  Late-Col Excess-Col Carri-Sen
>    Runts
>Giants
>Gi1/0/13           0
>        0  
>      0    
>     0      
>   0  17247538
>0
>
># show interfaces counters trunk
>
>Port        TrunkFramesTx  TrunkFramesRx  
>WrongEncap
>...
>Gi1/0/13        100127338    
>  100622824        
>  0
>...
>Gi1/0/22        237026205    
>  213296059        
>  0
>...
>
>Обьясните почему на этих двух портах счётчики не нулевые, в отличие от
>
>остальных?

show int на эти интерфейсы покажите..

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Ошибки на интерфейсе Catalyst 3750"  +/
Сообщение от uanic (ok) on 26-Янв-06, 16:00 
>show int на эти интерфейсы покажите..
#show interfaces gigabitEthernet 1/0/13
GigabitEthernet1/0/13 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000e.38a8.c60d (bia 000e.38a8.c60d)
  Description: SRV-ROUTER trunk
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  output flow-control is off, input flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters 1w6d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 897000 bits/sec, 123 packets/sec
  5 minute output rate 1325000 bits/sec, 202 packets/sec
     85405134 packets input, 1380568086 bytes, 0 no buffer
     Received 0 broadcasts (0 multicast)
     17886172 runts, 0 giants, 0 throttles
     17886172 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     102798814 packets output, 1317183707 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

and

#show interfaces gigabitEthernet 1/0/22
GigabitEthernet1/0/22 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000e.38a8.c616 (bia 000e.38a8.c616)
  Description: Trunk to 3COM 192.168.254.11 (Developers)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  output flow-control is off, input flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 1w6d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 60000 bits/sec, 48 packets/sec
  5 minute output rate 404000 bits/sec, 64 packets/sec
     219306265 packets input, 925899008 bytes, 0 no buffer
     Received 749384 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 568571 multicast, 0 pause input
     0 input packets with dribble condition detected
     243358506 packets output, 309579543 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Если ещё актуально..."  +/
Сообщение от andrey_mpb (ok) on 11-Июл-06, 16:02 
Cisco Catalyst 2970 Series Switches
Field Notice: FN - 61810 - C2970, C3560, and C3750 Incorrectly Report Errors on Dot1q Interfaces




Document ID: 62101


Revised October 20, 2005
September 14, 2004

--------------------------------------------------------------------------------

NOTICE:

THIS FIELD NOTICE IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTY OF MERCHANTABILITY. YOUR USE OF THE INFORMATION ON THE FIELD NOTICE OR MATERIALS LINKED FROM THE FIELD NOTICE IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS FIELD NOTICE AT ANY TIME.

Products Affected
All products

Problem Description
When using dot1q on trunk interfaces on the C2970, C3560 and C3750, runts may be seen on the show interface output.

The interface LED may also blink amber.

No connectivity failures are experienced. All network traffic passes normally.

Background
Valid dot1q encapsulated packets, which are 61 to 64 bytes including the q-tag, are counted by the affected devices as undersized frames.

The counting and reporting is erroneous. Network traffic is forwarded correctly. This problem does not affect network data, but solely the interface reporting.

Problem Symptoms
When using dot1q on trunk interfaces on the Cat3750, runts may be seen on the show interface output. The interface LED may blink amber and these packets are not reported in the appropriate unicast, multicast, or broadcast category in receive statistics.

Workaround/Solution
The problem is resolved in the following releases of Cisco IOS software:

Cisco IOS release 12.1(19)EA1d

Cisco IOS release 12.1(20)EA1a

Cisco IOS release 12.1(22)EA1 or later

Cisco IOS release 12.2(20)SE1 or later

It is not necessary to upgrade to one of the fixed releases, as this problem is purely cosmetic and does not affect the functionality of the device. However, the false display of errors will not occur if an upgrade to one of these releases is performed.

DDTS
To follow the bug ID link below and see detailed bug information, you must be a registered user and you must be logged in.

DDTS
Description

CSCec14238 (registered customers only)
3750 connected using dot1q cause Runts increase on interface

CSCec53648 (registered customers only)
61-64 byte dot1q frames trigger LED to blink amber


For More Information
If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Open a service request on Cisco.com
By email
By telephone
Receive Email Notification For New Field Notices
Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.

--------------------------------------------------------------------------------


--------------------------------------------------------------------------------
Updated: Oct 20, 2005 Document ID: 62101

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Если ещё актуально..."  +/
Сообщение от uanic (ok) on 12-Июл-06, 09:16 
Благодарю за ссылку. Я как раз вчера вернулся к этой проблеме. Скорее всего буду обновлять IOS.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Если ещё актуально..."  +/
Сообщение от alexrn email(ok) on 16-Фев-15, 13:50 
> Благодарю за ссылку. Я как раз вчера вернулся к этой проблеме. Скорее
> всего буду обновлять IOS.

У меня стоит обновленная версия
Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(50)SE5, RELEASE SOFTWARE (fc1)

И ошибки все-равно идут. Ниже подробная информация
#show interfaces GigabitEthernet 1/0/7 counters errors

Port        Align-Err     FCS-Err    Xmit-Err     Rcv-Err  UnderSize  OutDiscards
Gi1/0/7             0         142           0         142          0        33378
Port      Single-Col  Multi-Col   Late-Col  Excess-Col  Carri-Sen      Runts     Giants
Gi1/0/7            0          0          0           0          0          0          0

#show interfaces counters trunk
Gi1/0/7                 0               0            0

#show interfaces GigabitEthernet 1/0/7
GigabitEthernet1/0/7 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is ----.----.---- (bia ----.----.----)
  Description: P2000 Array Controller/Top
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  Media-type configured as  connector
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 33378
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 6000 bits/sec, 3 packets/sec
     81626118 packets input, 75658520521 bytes, 0 no buffer
     Received 320928 broadcasts (301617 multicasts)
     0 runts, 0 giants, 0 throttles
     143 input errors, 143 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 301617 multicast, 0 pause input
     0 input packets with dribble condition detected
     736927451 packets output, 71167510621 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


Подскажите пожалуйста в чем может быть дело?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor