The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Squid + mikrotik = логи???"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Настройка Squid и других прокси серверов (Учет работы пользователей, логи)
Изначальное сообщение [ Отслеживать ]

"Squid + mikrotik = логи???"  +/
Сообщение от jabahutt (ok) on 16-Дек-14, 09:35 
Есть сеть 192.168.168.0/24. Адреса раздает микротик (192.168.168.1), он же шлюз. Встала необходимость логировать сеть, на микротике созданы правила:
ip firewall nat add chain=dstnat action=accept protocol=tcp src-address-list=192.168.168.254 dst-port=80
ip firewall nat add chain=dstnat action=dst-nat protocol=tcp src-address-list=clients dst-port=80 to-addresses=192.168.168.254 to-ports=3128

Где 192.168.168.254 - адрес сквида
clients - клиентская сеть.

Также на микротике создан маршрут:
/ip route
add check-gateway=ping distance=1 gateway=192.168.168.254 routing-mark=web

Есть мангл:
/ip firewall mangle add action=mark-routing chain=prerouting comment="proxy" dst-port=80 new-routing-mark=web protocol=tcp src-address=!192.168.168.254

На машинке со сквидом (он транспарент) есть правила в rc.local
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j DNAT --to 192.168.168.254:3128
route add -net 192.168.168.0 netmask 255.255.255.0 gw 192.168.168.1 dev eth0

В результате в логах сквида адрес только микротика (192.168.168.1). Подскажите где косячу, люди добрые.


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Squid + mikrotik = логи???"  +/
Сообщение от Alex_kl (??) on 18-Дек-14, 23:58 
> ip firewall nat add chain=dstnat action=accept protocol=tcp src-address-list=192.168.168.254
> dst-port=80
> ip firewall nat add chain=dstnat action=dst-nat protocol=tcp src-address-list=clients
> dst-port=80 to-addresses=192.168.168.254 to-ports=3128

Я не силён в микротике, но судя по этим 2м правилам у вас NAT на 192.168.1.1, то есть все запросы в сквид будут приходить от этого адреса.

Вариант, вместо микротика ставить Linux + транспарентный squid.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Squid + mikrotik = логи???"  +/
Сообщение от ipmanyak (ok) on 19-Дек-14, 15:27 
MIKROTIK :Howto Redirect HTTP traffic to SQUID with Original Source Client IP
https://aacable.wordpress.com/2011/07/21/mikrotik-howto-redi.../

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру