The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"VOIP - односторонняя слышимость"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]
Курсы по Juniper Junos в Москве и Петербурге
"VOIP - односторонняя слышимость"  +/
Сообщение от Konstantin_PL (ok), 03-Окт-19, 15:14 
День добрый, коллеги!
Тема такая, cisco2820 в качестве телефонного шлюза. Со стороны Е1 - АТС М-200, со стороны IP - Asterisk.
Вызовы проходят, но слышимость в одну сторону. С астериска через шлюз, через АТС на сотовый всё слышно. Обратно голос не ходит.
Всё в одной подсети, никаких NAT.
Ставлю на это же место cisco1760, с аналогичными настройками - всё работает на ура.
Сделал вывод, косяк именно в настройках (а может и в софте) c-2820.

Я бы сказал, что какой то файрвол не пускает голосовой трафик с интерфейса, но ACL не настроены.
Что посоветуете? Снифером непосредственно на интерфейсе посмотрю, когда добирусь до объекта, он на достаточном удалении от меня.

Пока предлагаю конфиг, может кто то даст совет, куда копать...

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname voip-gw3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
clock timezone YEKT 5
network-clock-participate wic 1
no ip routing
!
no ip cef
!
ip domain name voip-gw3.voip
ip name-server 192.168.100.8
ip inspect name VOIP sip
!
multilink bundle-name authenticated
!
isdn switch-type primary-net5
isdn voice-call-failure 0
!
voice-card 0
no dspfarm
!
voice hunt user-busy
voice call send-alert
voice call convert-discpi-to-prog
voice rtp send-recv
!
voice service voip
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
voice class custom-cptone Russia
dualtone busy
  frequency 425
  cadence 350 350
dualtone ringback
  frequency 425
  cadence 500 1000
dualtone reorder
  frequency 425
  cadence 350 350
!
controller E1 0/1/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/1/1
framing NO-CRC4
pri-group timeslots 1-31
!
translation-rule 55
Rule 0 ^5592... 92
!
interface GigabitEthernet0/0
no ip address
no ip route-cache
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/0.50
description VoIP interface
encapsulation dot1Q 50
ip address 192.168.100.9 255.255.255.0
no ip route-cache
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no keepalive
no cdp enable
!
interface Serial0/1/1:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no keepalive
no cdp enable
!
ip default-gateway 192.168.100.254
ip route 0.0.0.0 0.0.0.0 192.168.100.254
ip route 192.168.200.0 255.255.255.0 192.168.100.254
!
no ip http server
no ip http secure-server
!
logging trap debugging
!
control-plane
!
voice-port 0/1/0:15
no vad
no comfort-noise
cptone RU
bearer-cap Speech
!
voice-port 0/1/1:15
no vad
no comfort-noise
cptone RU
bearer-cap Speech
!
dial-peer voice 1 voip
description IN from IP net
huntstop
answer-address .T
voice-class codec 1
!
dial-peer voice 2 pots
description IN from E1 net
preference 1
incoming called-number [5][5].T
no digit-strip
direct-inward-dial
forward-digits all
!
dial-peer voice 1002 pots
description OUT from IP to E1
destination-pattern 0.$
port 0/1/0:15
forward-digits all
!
dial-peer voice 1003 pots
description OUT from IP to E1
destination-pattern 8..........
port 0/1/0:15
forward-digits all
!
dial-peer voice 1004 pots
description OUT from IP to E1
destination-pattern 810...............
port 0/1/0:15
forward-digits all
!
dial-peer voice 1005 pots
description OUT from IP to E1
destination-pattern [2479]....$
port 0/1/0:15
forward-digits all
!
dial-peer voice 1006 pots
description OUT from IP to E1
destination-pattern 118..$
port 0/1/0:15
forward-digits all
!
dial-peer voice 1000 voip
description FOR 5592XXX
destination-pattern 5592...$
translate-outgoing called 55
voice-class codec 1
session protocol sipv2
session target ipv4:192.168.100.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 998 pots
description OUT from IP to E1
destination-pattern 112$
port 0/1/0:15
forward-digits all
!
sip-ua
no redirection
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry options 0
timers trying 1000
!
line con 0
exec-timeout 0 0
login local
line aux 0
exec-timeout 0 0
password 7 011F020E59131F1C305E4407
login local
transport input telnet
line vty 0 4
exec-timeout 0 0
password 7 082D48440B011C040319060A
login local
transport input telnet
!
scheduler allocate 20000 1000
ntp clock-period 17180363
ntp server 192.168.100.2 prefer
ntp server 80.241.0.72
ntp server 195.191.82.4
!
end

Заранее спасибо за уделённое внимание....

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "VOIP - односторонняя слышимость"  +/
Сообщение от Пыня (?), 06-Окт-19, 01:00 
А дамп можно который по порту sip?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "VOIP - односторонняя слышимость"  +/
Сообщение от Konstantin_PL (ok), 28-Окт-19, 10:11 
> А дамп можно который по порту sip?

Я снял дамп при помощи wireshark, там чётко видно, что RTP идёт только в одну сторону. Обратного трафика просто нет. Так что версия с не совпадающими голосовыми портами не состоятельна.
К сожалению не вижу как сюда прицепить файл. Выложил на диск: https://yadi.sk/d/OWvIDaLkIWm2qQ
192.168.100.1 - asterisk
192.168.100.9 - cisco
192.168.100.51 - ip телефон, с которого делался вызов.
Была возможность, поставил в циску модуль NM-HDV, с ещё одним модулем 2*Е1 и собственными DSP.
Результат тот же. В одну сторону голос есть, обратно нет. Было подозрение на нерабочие DSP, но для себя лично я не смог объяснить с технической точки зрения, почему голос есть в одну сторону.
Ну в общем пока тупик.
Ещё касательно конфигурации...

System image file is "flash:c2800nm-adventerprisek9-mz.124-11.T.bin"

Cisco 2821 (revision 53.51) with 509952K/14336K bytes of memory.
Processor board ID FTX1327AH72
2 Gigabit Ethernet interfaces
93 Serial interfaces
4 Channelized E1/PRI ports
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
250368K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Если есть соображения - буду рад услышать.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

6. "VOIP - односторонняя слышимость"  +/
Сообщение от Andrey (??), 28-Окт-19, 11:49 
>[оверквотинг удален]
> Processor board ID FTX1327AH72
> 2 Gigabit Ethernet interfaces
> 93 Serial interfaces
> 4 Channelized E1/PRI ports
> 1 Virtual Private Network (VPN) Module
> DRAM configuration is 64 bits wide with parity enabled.
> 239K bytes of non-volatile configuration memory.
> 250368K bytes of ATA CompactFlash (Read/Write)
> Configuration register is 0x2102
> Если есть соображения - буду рад услышать.

В каком месте снимался дамп?
Снимите три дампа: на Cisco, на Asterisk(в сторону Cisco и в сторону телефона), на самом телефоне. Проверьте в каком месте поток идет только в одну сторону.
Запретите на Asterisk RTP бегать напрямую.


Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "VOIP - односторонняя слышимость"  +/
Сообщение от Константин (??), 29-Окт-19, 07:29 
>[оверквотинг удален]
>> DRAM configuration is 64 bits wide with parity enabled.
>> 239K bytes of non-volatile configuration memory.
>> 250368K bytes of ATA CompactFlash (Read/Write)
>> Configuration register is 0x2102
>> Если есть соображения - буду рад услышать.
> В каком месте снимался дамп?
> Снимите три дампа: на Cisco, на Asterisk(в сторону Cisco и в сторону
> телефона), на самом телефоне. Проверьте в каком месте поток идет только
> в одну сторону.
> Запретите на Asterisk RTP бегать напрямую.

Схема:
АТС => cisco => asterisk => телефон

Снимал с порта циски. Ну раз с циски не уходит, понятно что на астериск и на телефон не приходит. На астериске тоже смотрел, когда начал вычислять проблему, пусто там на входе, не смотря на отключение файрвола.
Есть конечно вариант, что на циску не приходит с АТС в Е1 потоке, ну это уже из области фантастики...

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "VOIP - односторонняя слышимость"  +/
Сообщение от eek (ok), 29-Окт-19, 13:55 
> Схема:
> АТС => cisco => asterisk => телефон

удалено.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

7. "VOIP - односторонняя слышимость"  +/
Сообщение от BJ (ok), 28-Окт-19, 14:44 
Вы включили cef и роутинг ?
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

2. "VOIP - односторонняя слышимость"  +/
Сообщение от Andrey (??), 06-Окт-19, 12:00 
>[оверквотинг удален]
>  transport input telnet
> !
> scheduler allocate 20000 1000
> ntp clock-period 17180363
> ntp server 192.168.100.2 prefer
> ntp server 80.241.0.72
> ntp server 195.191.82.4
> !
> end
> Заранее спасибо за уделённое внимание....

Скорее всего какая-то из сторон пытается послать голос выходя за диапазон принимающей стороны.
Снимите дамп на Cisco с помощью packet capture.
Посмотрите диапазон портов для голоса на Asterisk. Установленный по умолчанию не совпадает с диапазоном, используемым Cisco.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "VOIP - односторонняя слышимость"  +/
Сообщение от BJ (ok), 06-Окт-19, 21:34 
CEF включи

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "VOIP - односторонняя слышимость"  +/
Сообщение от BJ (ok), 06-Окт-19, 21:44 
И роутинг тоже
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

9. "VOIP - односторонняя слышимость"  +/
Сообщение от Константин (??), 29-Окт-19, 10:41 
> И роутинг тоже

День добрый!

CEF я включил, а вот роутинг не заметил. Сказывается отсутствие опыта по работе с данной моделью цисок. Ну и не часто приходится браться за проекты на данном оборудовании.

Спасибо, включил роутинг и всё заработало!

Тему можно закрывать.
Ещё раз спасибо!

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру