The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с Calling Party Number"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"Проблема с Calling Party Number"  +/
Сообщение от diggge (ok) on 15-Мрт-12, 04:31 
Добрый день!! Есть связка CUCM <->голосовой шлюз 2911(call manager) <-> ТФОП(по E1).
CUCM и голосовой шлюз общаются по SIP, дальше в город выходит через цифровой поток Е1. В телефоны с CUCM могли звонить внутри города, но на межгород и на сотовые провайдер пускал, так как провайдер требовал значение | screening: network provided либо user-provided verified & passed, а от нас шло screening: user provided not screened.
Проблема решилась добавлением команды
voice service voip
clid network-provided
После этого от нас к провайдеру идет | screening: network provided и все работает.
Далее появилось необходимость на самом голосовом шлюзе(call manager express) зарегистрировать телефоны по SCCP. История повторилась, к провайдеру идет с телефонов зарегистрированных на CME screening: user provided not screened. Итог: телефоны с CME никак не могут выйти на сотовые и межгород.
Прилагаю необходимые конфиги для с2911.
card type e1 0 0
logging buffered informational

ip dhcp pool VOICEtest
network 10.1.8.0 255.255.255.0
default-router 10.1.8.1
option 150 ip 10.1.8.1
option 66 ip 10.1.8.1

isdn switch-type primary-net5


voice-card 0
dspfarm
dsp services dspfarm

voice call disc-pi-off
!
voice service pots
!
voice service voip
clid network-provided
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
redirect ip2ip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server

voice class codec 2
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g723ar53
codec preference 4 g723ar63
codec preference 5 g723r53
codec preference 6 g723r63
codec preference 7 g729br8
codec preference 8 g729r8
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g729br8

voice translation-rule 3
rule 1 /^3/ /493/ type any subscriber
!
voice translation-rule 4
rule 1 /^9/ /9/ type any subscriber
!
voice translation-rule 5
rule 1 /^9/ /9/ type any national
!
voice translation-rule 6
rule 1 /^3/ /493/ type any national
!
voice translation-profile dobav_6
translate calling 6
translate called 3
!
voice translation-profile type_subscriber
translate calling 5
translate called 4
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.7
encapsulation dot1Q 7
ip address 10.1.7.253 255.255.255.0
!
interface GigabitEthernet0/1.30
encapsulation dot1Q 30
ip address 10.1.30.2 255.255.255.0
!
!
interface GigabitEthernet0/1.999
encapsulation dot1Q 999
ip address 10.1.8.1 255.255.255.0
!
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn timer T310 60000
isdn overlap-receiving
isdn incoming-voice voice
isdn calling-party-num network-provided
isdn sending-complete
isdn outgoing display-ie

voice-port 0/0/0:15
echo-cancel coverage 32


mgcp profile default
!
sccp local GigabitEthernet0/1.999
sccp ccm 10.1.8.1 identifier 1 priority 1 version 7.0
sccp
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
maximum sessions 1
associate application SCCP
shutdown
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 6
associate application SCCP
!

dial-peer voice 1 pots
description IN-E1
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 104 pots
translation-profile outgoing type_subscriber
huntstop
destination-pattern 98..........
direct-inward-dial
port 0/0/0:15
forward-digits all
!
dial-peer voice 105 pots
destination-pattern 9[1234567].....
direct-inward-dial
port 0/0/0:15
forward-digits all
!

!
telephony-service
sdspfarm transcode sessions 16
max-ephones 58
max-dn 300
rollback ip-switching
rollback pass-unexpected-codec
ip source-address 10.1.8.1 port 2000
auto assign 1 to 10 type 7911
no caller-id name-only
user-locale RU
load 7911 SCCP11.8-4-4S
time-zone 47
time-format 24
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Mar 12 2012 15:10:42
!
!
ephone-dn 1 octo-line
number 3696
name 3696
!
!
ephone 1
mac-address 88F0.7789.EFBF
type 7911
button 1:1

При трассировке звонка выскакивает

074138: Mar 14 17:53:55 yak: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 3696
074139: Mar 14 17:53:55 yak: ISDN Se0/0/0:15 Q931: Sending SETUP callref = 0x066F callID = 0x85F1 switch = primary-net5 interface = User
074140: Mar 14 17:53:55 yak: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x066F
Sending Complete
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA9839F
Exclusive, Channel 31
Progress Ind i = 0x8183 - Origination address is non-ISDN
Display i = '3696'
Calling Party Number i = 0x0180, '3696'
Plan:ISDN, Type:Unknown
Called Party Number i = 0xC1, '989147895848'
Plan:ISDN, Type:Subscriber(local)
074141: Mar 14 17:53:55 yak: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x866F
Channel ID i = 0xA9839F
Exclusive, Channel 31
074142: Mar 14 17:53:57 yak: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x866F
Cause i = 0x8390 - Normal call clearing
074143: Mar 14 17:53:57 yak: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x066F
074144: Mar 14 17:53:57 yak: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x866F

При звонке с CUCM-> голосовой шлюз -> E1 звонки проходят

074145: Mar 14 17:55:24 yak: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 3649
074146: Mar 14 17:55:24 yak: ISDN Se0/0/0:15 Q931: Sending SETUP callref = 0x0670 callID = 0x85F2 switch = primary-net5 interface = User
074147: Mar 14 17:55:24 yak: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0670
Sending Complete
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA9839F
Exclusive, Channel 31
Display i = '3649'
Calling Party Number i = 0x0183, '3649'
Plan:ISDN, Type:Unknown
Called Party Number i = 0xC1, '989147895848'
Plan:ISDN, Type:Subscriber(local)
074148: Mar 14 17:55:24 yak: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8670
Channel ID i = 0xA9839F
Exclusive, Channel 31
074149: Mar 14 17:55:28 yak: ISDN Se0/0/0:15 Q931: RX <- ALERTING pd = 8 callref = 0x8670
074150: Mar 14 17:55:30 yak: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x0670
Cause i = 0x8090 - Normal call clearing
074151: Mar 14 17:55:30 yak: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x8670
074152: Mar 14 17:55:30 yak: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0670

Как я понимаю,
Calling Party Number i = 0x0180, это screening: user provided not screened, а Calling Party Number i = 0x0183 это screening: network provided.
На E1 выходим с префиксом 9, провайдер его сам убирает, и в начале добавляет 2 цифры.

И так вопрос, как при звонке с телефонов зарегистрированных по SCCP на cme через поток Е1 поменять значение с screening: user provided not screened на network provided. Предполагаю меняется где то на telephony-service. Выслушаю любые предположения. Возможно вопрос глупый ввиду незнания автора некоторых вещей
Перепробовал разные команды .пока не нашел решение.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с Calling Party Number"  +/
Сообщение от eek email on 15-Мрт-12, 08:58 
translation profiles не спасают?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Проблема с Calling Party Number"  +/
Сообщение от diggge (ok) on 15-Мрт-12, 10:45 
> translation profiles не спасают?

как я знаю через translation profiles меняется только type и plan

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Проблема с Calling Party Number"  +/
Сообщение от eek email on 15-Мрт-12, 12:40 
>> translation profiles не спасают?
> как я знаю через translation profiles меняется только type и plan

В таком разе видимо никак, просите встречную сторону помочь.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Проблема с Calling Party Number"  +/
Сообщение от user (??) on 16-Мрт-12, 10:51 
> так как провайдер
> требовал значение | screening: network provided либо user-provided verified & passed,

- испросите у вашего провайдера на каком основании они требуют от вас выполнения этого условия.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Проблема с Calling Party Number"  +/
Сообщение от Radek on 24-Ноя-14, 20:07 
You can try a comand in the dial peer
clid network-provided

test it, it may work.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor