The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



" ospf через dmvpn попадает ненужный маршрут"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

" ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от cr1m2 (ok), 04-Июл-18, 08:14 
Здравствуйте, есть 2 роутера cisco 29XX, между ними поднят nhrp, первый в режиме хаба, второй спок. В dmvpn поднят ospf и вижу что с хаба на спок приходит ненужный маршрут, не пойму почему такое происходит. Вот конфиг хаба:

interface Tunnel1
ip address 192.168.35.1 255.255.255.240
no ip redirects
ip nhrp authentication 111
ip nhrp network-id 123123
ip ospf network broadcast
ip ospf hello-interval 60
ip ospf priority 10
ip ospf mtu-ignore
cdp enable
tunnel source GigabitEthernet0/2
tunnel mode gre multipoint
tunnel key 123123

interface GigabitEthernet0/0
description LAN
ip address 192.168.32.18 255.255.255.248
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip policy route-map rt_inet
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WAN 1
ip address X.X.26.164 255.255.255.248 secondary
ip address X.X.26.163 255.255.255.248
ip access-group incoming in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in max-fragments 64 max-reassemblies 1024
ip virtual-reassembly out max-fragments 64 max-reassemblies 1024
duplex auto
speed auto
no cdp tlv app
!
interface GigabitEthernet0/2
description RT
ip address Z.Z.88.114 255.255.255.248
ip access-group incoming in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in max-fragments 64 max-reassemblies 1024
ip virtual-reassembly out max-fragments 64 max-reassemblies 1024
duplex auto
speed auto
no cdp tlv app

!
router ospf 11
router-id 192.168.32.18
passive-interface default

no passive-interface Tunnel 1
no passive-interface GigabitEthernet0/0
network 192.168.32.16 0.0.0.7 area 2
network 192.168.35.0 0.0.0.15 area 0
!

Т.е. он по ospf в dmvpn зону backbone 0 пересылает маршруты из area 2 и соотвественно сети указанные в router ospf 11.

На споке конфиг:

interface Tunnel1
ip address 192.168.35.7 255.255.255.240
no ip redirects
ip nhrp authentication 111
ip nhrp map multicast Z.Z.88.114
ip nhrp map 192.168.35.1 Z.Z.88.114
ip nhrp network-id 123123
ip nhrp holdtime 60
ip nhrp nhs 192.168.35.1
ip nhrp registration timeout 60
ip ospf network broadcast
ip ospf hello-interval 60
ip ospf priority 0
cdp enable
tunnel source GigabitEthernet0/2
tunnel mode gre multipoint
tunnel key 123123

!

interface GigabitEthernet0/0
description WANMain
ip address Y.Y.123.165 255.255.255.192
ip access-group incoming in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in max-fragments 64 max-reassemblies 1024
ip virtual-reassembly out max-fragments 64 max-reassemblies 1024
ip tcp adjust-mss 1460
duplex auto
speed 100
no cdp tlv app
!
interface GigabitEthernet0/1
description LAN
ip address 192.168.32.2 255.255.255.248
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip policy route-map rostelekom-inet
duplex auto
speed auto
!
interface GigabitEthernet0/2
description BACKUP WAN
ip address Y.Y.208.154 255.255.255.248
ip access-group incoming in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no cdp tlv app

!

router ospf 11
router-id 192.168.32.2
passive-interface default
no passive-interface GigabitEthernet0/1

no passive-interface Tunnel 1
network 192.168.32.0 0.0.0.7 area 1
network 192.168.35.0 0.0.0.15 area 0
!

Но на споке при поднятом ospf backbone 0 вижу маршрут от хаба:

O E2 X.X.26.160/29 [110/20] via 192.168.35.1, 00:04:59, Tunnel1

эта сеть закреплена на интерфейсе GigabitEthernet0/1 хаба, который не участвует в ospf.

Как такое может быть тогда?


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от cr1m2 (ok), 04-Июл-18, 12:37 
Попробовал зафильтровать на хабе анонс этой сети

access-list 50 deny X.X.26.160 0.0.0.7
access-list 50 permit any

router ospf 11
router-id 192.168.32.18
passive-interface default
no passive-interface GigabitEthernet0/0
network 192.168.32.16 0.0.0.7 area 2
network 192.168.35.0 0.0.0.15 area 0
distribute-list 50 out


Но почему роутер пытается ее анонсировать остается загадкой...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от qq (??), 04-Июл-18, 14:45 
>[оверквотинг удален]
> access-list 50 deny X.X.26.160 0.0.0.7
> access-list 50 permit any
> router ospf 11
>  router-id 192.168.32.18
>  passive-interface default
>  no passive-interface GigabitEthernet0/0
>  network 192.168.32.16 0.0.0.7 area 2
>  network 192.168.35.0 0.0.0.15 area 0
>  distribute-list 50 out
> Но почему роутер пытается ее анонсировать остается загадкой...

сори за оффтоп. 2 железки динамика. зачем? смысла не могу понять. тс объясните  плз.


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от cr1m2 (ok), 04-Июл-18, 15:15 

> сори за оффтоп. 2 железки динамика. зачем? смысла не могу понять. тс
> объясните  плз.

Дело в том что всего железок 7, в тесте запустил пока на 2х. Раньше туннель был настроен на хабе на том интерфейсе, чью сеть хаб анонсирует в ospf через туннель и все споки сразу разрывали туннели.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от Andrey (??), 04-Июл-18, 15:38 
>> сори за оффтоп. 2 железки динамика. зачем? смысла не могу понять. тс
>> объясните  плз.
> Дело в том что всего железок 7, в тесте запустил пока на
> 2х. Раньше туннель был настроен на хабе на том интерфейсе, чью
> сеть хаб анонсирует в ospf через туннель и все споки сразу
> разрывали туннели.

O E2 ?  
Редистрибуцией никто не занимается на других железках?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от cr1m2 (ok), 05-Июл-18, 07:31 
>>> сори за оффтоп. 2 железки динамика. зачем? смысла не могу понять. тс
>>> объясните  плз.
>> Дело в том что всего железок 7, в тесте запустил пока на
>> 2х. Раньше туннель был настроен на хабе на том интерфейсе, чью
>> сеть хаб анонсирует в ospf через туннель и все споки сразу
>> разрывали туннели.
> O E2 ?
> Редистрибуцией никто не занимается на других железках?

Да, спасибо! нашел действительно редистрибьюцию этого маршрута. За хабом еще один роутер есть, который передает ему маршруты согласно настройке


router ospf 11
router-id 192.168.32.17
network 192.168.32.16 255.255.255.240 area 2
log-adj-changes
redistribute connected subnets
distribute-list ripACL_FR out ospf 11

А к нему подклчена сеть X.X.26.160, т.е. он шлет маршрут об этой сети как
redistribute connected subnets

Но вот правило
distribute-list ripACL_FR out ospf 11

которое
access-list ripACL_FR standard deny X.X.26.160 255.255.255.248
access-list ripACL_FR standard permit any4
по идее должно запрещать анонс этой сети, а  этого не происходит.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. " ospf через dmvpn попадает ненужный маршрут"  +/
Сообщение от cr1m2 (ok), 05-Июл-18, 07:55 
>
> router ospf 11
>  router-id 192.168.32.17
>  network 192.168.32.16 255.255.255.240 area 2
>  log-adj-changes
>  redistribute connected subnets
>  distribute-list ripACL_FR out ospf 11

Поправил
distribute-list ripACL_FR out ospf 11
на
distribute-list ripACL_FR out

Сеть перестала приходить

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor