The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"то заходит по ssh то нет"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"то заходит по ssh то нет"  +/
Сообщение от tamplier (ok) on 24-Окт-11, 18:33 
доброго времени суток ! проблема такого плана. есть сконфигурированная cisco 2600, проделанны все манипуляции по созданию доступа через ssh. и тут всплывает сама проблема. в одном случае из десяти вход через ссш происходит, иногда совсем передумывает заходить ! конфиг выложу прям рано утром, просто интересно, может быть кто-то уже сталкивался с сим "непотребством"? :). премног буду благодарен за интерес к вопросу !
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "то заходит по ssh то нет"  +/
Сообщение от Николай_kv on 24-Окт-11, 18:48 
> доброго времени суток ! проблема такого плана. есть сконфигурированная cisco 2600, проделанны
> все манипуляции по созданию доступа через ssh. и тут всплывает сама
> проблема. в одном случае из десяти вход через ссш происходит, иногда
> совсем передумывает заходить ! конфиг выложу прям рано утром, просто интересно,
> может быть кто-то уже сталкивался с сим "непотребством"? :). премног буду
> благодарен за интерес к вопросу !

Может у тебя все линии vty кто-то держит?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "то заходит по ssh то нет"  +/
Сообщение от shadow_alone (ok) on 24-Окт-11, 19:10 
> Может у тебя все линии vty кто-то держит?

Скорее всего так и есть. Нет настройки таймаута для линий.
Настройте правильно ssh, и сделайте лимит времени на линии, тогда сессии будут рваться и освобождаться.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "то заходит по ssh то нет"  +/
Сообщение от tamplier (ok) on 25-Окт-11, 07:45 
>> Может у тебя все линии vty кто-то держит?
> Скорее всего так и есть. Нет настройки таймаута для линий.
> Настройте правильно ssh, и сделайте лимит времени на линии, тогда сессии будут
> рваться и освобождаться.

Огромное спасибо что откликнулись !!!!! :) тайм аут, прописан, как мне кажется вот конфиг

>>>sh run

Current configuration : 2196 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname alterra
!
aaa new-model
!
!
aaa session-id common
enable secret 5 $1$IkVQ$.hzRguNQuMIaYOrDn9Yxa0
enable password 7 070C285F4D064B534742
!
username test privilege 3 secret 5 $1$pNJm$Hqajr5eQfp5C0c.SffXmC.
username admin privilege 3 secret 5 $1$rEam$J85fBSfF4mqlRf2xn2kVX1
ip subnet-zero
no ip routing
!
!
ip domain name alterra.su
ip name-server 87.241.226.3
ip name-server 87.241.223.68
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!        
ip dhcp pool office
   network 192.168.1.0 255.255.255.0
   dns-server 87.241.226.3 87.241.223.68
   default-router 192.168.1.1
!        
vpdn enable
!        
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!        
!        
!        
!        
voice call carrier capacity active
!        
!        
!        
!        
!        
!        
!        
!        
!        
mta receive maximum-recipients 0
!        
!        
!        
!        
interface FastEthernet0/0
ip address 46.52.217.114 255.255.255.252
ip nat outside
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!        
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!        
interface Virtual-Template1
ip unnumbered FastEthernet0/0
no ip route-cache
no keepalive
peer default ip address pool test
ppp encrypt mppe 40
ppp bridge ip
ppp authentication chap ms-chap userppp
!        
ip local pool test 192.168.1.40 192.168.1.50
ip nat inside source list NAT interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.245 81 46.52.217.114 47111 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 46.52.217.113
no ip http server
!        
!        
ip access-list extended NAT
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended protocol
!        
access-list 23 permit 192.168.0.0 0.0.0.255
no cdp run
!        
snmp-server community STAT RO
snmp-server enable traps tty
call rsvp-sync
!        
!        
mgcp profile default
!        
dial-peer cor custom
!        
!        
!        
!        
!        
line con 0
password 7 14161E1F0916382A
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 60 0
privilege level 3
password 7 0251510B52575D781A
logging synchronous
transport input ssh
!        
!        
end      


корявенько...., однако все что требуется дает, кроме стабильного SSH.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "то заходит по ssh то нет"  +/
Сообщение от shadow_alone (ok) on 25-Окт-11, 08:17 
> line vty 0 4
>  access-class 23 in
>  exec-timeout 60 0
>  privilege level 3
>  password 7 0251510B52575D781A
>  logging synchronous
>  transport input ssh

absolute-timeout 60

и еще можете увеличить session-limit (количество сессий)

а что б уж точно наверняка, когда зайдете, посмотрите заняты ли сессии.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "то заходит по ssh то нет"  +/
Сообщение от tamplier (ok) on 25-Окт-11, 09:35 
>> line vty 0 4
>>  access-class 23 in
>>  exec-timeout 60 0
>>  privilege level 3
>>  password 7 0251510B52575D781A
>>  logging synchronous
>>  transport input ssh
> absolute-timeout 60
> и еще можете увеличить session-limit (количество сессий)
> а что б уж точно наверняка, когда зайдете, посмотрите заняты ли сессии.

Спасибо за ответ !!!!!!


>>sh run

Current configuration : 2234 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname alterra
!
aaa new-model
!
!
aaa session-id common
enable secret 5 $1$IkVQ$.hzRguNQuMIaYOrDn9Yxa0
enable password 7 070C285F4D064B534742
!
username test privilege 3 secret 5 $1$pNJm$Hqajr5eQfp5C0c.SffXmC.
username admin privilege 3 secret 5 $1$rEam$J85fBSfF4mqlRf2xn2kVX1
ip subnet-zero
no ip routing
!
!
ip domain name alterra.su
ip name-server 87.241.226.3
ip name-server 87.241.223.68
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!        
ip dhcp pool office
   network 192.168.1.0 255.255.255.0
   dns-server 87.241.226.3 87.241.223.68
   default-router 192.168.1.1
!        
vpdn enable
!        
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!        
!        
!        
!        
voice call carrier capacity active
!        
!        
!        
!        
!        
!        
!        
!        
!        
mta receive maximum-recipients 0
!        
!        
!        
!        
interface FastEthernet0/0
ip address 46.52.217.114 255.255.255.252
ip nat outside
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!        
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!        
interface Virtual-Template1
ip unnumbered FastEthernet0/0
no ip route-cache
no keepalive
peer default ip address pool test
ppp encrypt mppe 40
ppp bridge ip
ppp authentication chap ms-chap userppp
!        
ip local pool test 192.168.1.40 192.168.1.50
ip nat inside source list NAT interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.245 81 46.52.217.114 47111 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 46.52.217.113
no ip http server
!        
!        
ip access-list extended NAT
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended protocol
!        
access-list 23 permit 192.168.0.0 0.0.0.255
no cdp run
!        
snmp-server community STAT RO
snmp-server enable traps tty
call rsvp-sync
!        
!        
mgcp profile default
!        
dial-peer cor custom
!        
!        
!        
!        
!        
line con 0
password 7 14161E1F0916382A
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 0 0
privilege level 3
password 7 0251510B52575D781A
absolute-timeout 60
session-limit 10
logging synchronous
transport input ssh
!        
!        
end      
  

выдает сообщение "The remote system refused the connection. This probably
means that the remote system does not provide the service you are attempting
to access , or that the service is being provided on a different port."

смысл понят а что конкретно в конфиге не камельфо ?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "то заходит по ssh то нет"  +/
Сообщение от tamplier (ok) on 25-Окт-11, 13:51 
>>> line vty 0 4
>>>  access-class 23 in
>>>  exec-timeout 60 0
>>>  privilege level 3
>>>  password 7 0251510B52575D781A
>>>  logging synchronous
>>>  transport input ssh
>> absolute-timeout 60
>> и еще можете увеличить session-limit (количество сессий)
>> а что б уж точно наверняка, когда зайдете, посмотрите заняты ли сесс

собака оказалась зарыта в access листах (мля) !!!! :)
поудалял к чертовой матери все access используемые при прописывании SSH, ну и как-то счастье :). Всем большое спасибо за внимание к теме !!!!!!!!!!!

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor