The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"Нет маршрутизации на cisco 1841"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Курсы по Juniper Junos в Москве и Петербурге
"Нет маршрутизации на cisco 1841"  +/
Сообщение от uncle_grin email(ok) on 16-Дек-17, 08:45 
Здравствуйте! Вопрос, наверное, дилетантский, но что-то я поплыл...
Суть в следующем: Имеется скажем так, провайдер, который раздает интернет с адреса 192.168.10.1. Имеется сетка 192.168.34.0 в которую этот интернет надо раздавать
Имеется Cisco 1841, с вот такой конфигурацией:
-------------------------------------------------
Using 2282 out of 196600 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname r1634
!
boot-start-marker
boot-end-marker
!
logging buffered 65565 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization console
aaa authorization exec default local
!
aaa session-id common
clock timezone MSK 3
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.34.1 192.168.34.99
ip dhcp excluded-address 192.168.34.201 192.168.34.254
!
ip dhcp pool LAN
   network 192.168.34.0 255.255.255.0
   default-router 192.168.34.1
   dns-server 70.30.254.121
   domain-name local
!
!
ip domain name local
ip name-server 78.30.254.121
ip name-server 8.8.8.8
!
!
!
username radmin privilege 15 secret 5 $1$UFqs$/1rRWACWhnLDC2zPlJxIp.
!
!
ip ssh version 2
!
!
!
!
interface FastEthernet0/0
description LAN
ip address 192.168.34.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description ISP
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 192.168.34.0 255.255.255.0 FastEthernet0/0
!
ip http server
no ip http secure-server
ip nat inside source list nat_interface interface FastEthernet0/1 overload
!
ip access-list extended nat_interface
deny   ip any 10.0.0.0 0.255.255.255
deny   ip any 172.16.0.0 0.15.255.255
deny   ip any 192.168.0.0 0.0.255.255
permit ip 192.168.34.0 0.0.0.255 any
ip access-list extended vty
permit ip 192.168.34.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
exec-timeout 30 0
logging synchronous
line aux 0
line vty 0 4
access-class vty in
logging synchronous
transport input ssh
transport output all
line vty 5 15
access-class vty in
exec-timeout 120 0
logging synchronous
transport input ssh
transport output all
!
scheduler allocate 20000 1000
ntp server 193.124.11.11
ntp server 194.149.67.130
ntp server 193.125.143.173
ntp server 193.125.143.172
ntp server 84.204.87.243
ntp server 80.249.135.2
ntp server 80.68.242.188
ntp server 194.87.0.20
ntp server 89.111.168.177
ntp server 194.33.191.69
ntp server 194.87.0.28
ntp server 81.200.8.213
end
-----------------------------
Интерфейс fa0/0 смотрит в локалку, имеет адрес 192.168.34.1
Интерфейс fa0/1 идет к провайдеру, адрес ему назначается DHCP провайдера (192.168.10.130)
Все порты подняты

С маршрутизатора пингуются: шлюз провайдера и тот же яндекс, проблем нет.
С маршрутизатора не пингуются машины сетки 192.168.34.0
Из сетки 192.168.34.0 пингуются интерфейсы cisco 192.168.34.1 и 192.168.10.130
Из 192.168.10.0 интерфейс Циски 192.168.10.130 так же пингуется.

Для сетки 192.168.34.0 адреса назначаются DHCP Циски, шлюзом стоит 192.168.34.1, на компьютерах это проходит нормально (они же видят Цисковский интерфейс смотрящий к провайдеру)

Теперь вопрос - как машинам из сети 192.168.34.0 увидеть шлюз провайдера (192.168.10.1) и соответственно получить доступ в интернет???
Что я делаю не так, где натупил???

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Нет маршрутизации на cisco 1841"  +/
Сообщение от Дмитрй email on 16-Дек-17, 21:25 
>[оверквотинг удален]
> Все порты подняты
> С маршрутизатора пингуются: шлюз провайдера и тот же яндекс, проблем нет.
> С маршрутизатора не пингуются машины сетки 192.168.34.0
> Из сетки 192.168.34.0 пингуются интерфейсы cisco 192.168.34.1 и 192.168.10.130
> Из 192.168.10.0 интерфейс Циски 192.168.10.130 так же пингуется.
> Для сетки 192.168.34.0 адреса назначаются DHCP Циски, шлюзом стоит 192.168.34.1, на компьютерах
> это проходит нормально (они же видят Цисковский интерфейс смотрящий к провайдеру)
> Теперь вопрос - как машинам из сети 192.168.34.0 увидеть шлюз провайдера (192.168.10.1)
> и соответственно получить доступ в интернет???
> Что я делаю не так, где натупил???

Ну я не вижу default route по умолчанию.
ip route 0.0.0.0  0.0.0.0 FastEthernet0/1


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Нет маршрутизации на cisco 1841"  +/
Сообщение от Алексей (??) on 16-Дек-17, 21:28 
Могу ошибаться.. С цисками уже лет 10 как не работал....

Для полной картины нужна таблица маршрутизации.
И мне от эта строчка не нравится
> ip route 192.168.34.0 255.255.255.0 FastEthernet0/0

Зачем железке говорить то, о чем она и так знает.
Если задаете маршрут по умолчанию то делается это так:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Нет маршрутизации на cisco 1841"  +/
Сообщение от Алексей (??) on 16-Дек-17, 21:29 
> Могу ошибаться.. С цисками уже лет 10 как не работал....
> Для полной картины нужна таблица маршрутизации.
> И мне от эта строчка не нравится
>> ip route 192.168.34.0 255.255.255.0 FastEthernet0/0
> Зачем железке говорить то, о чем она и так знает.
> Если задаете маршрут по умолчанию то делается это так:
> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Ошибся  FastEthernet0/1 конечно же

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Нет маршрутизации на cisco 1841"  +/
Сообщение от uncle_grin email(ok) on 16-Дек-17, 21:57 
>> Могу ошибаться.. С цисками уже лет 10 как не работал....
>> Для полной картины нужна таблица маршрутизации.
>> И мне от эта строчка не нравится
>>> ip route 192.168.34.0 255.255.255.0 FastEthernet0/0
>> Зачем железке говорить то, о чем она и так знает.
>> Если задаете маршрут по умолчанию то делается это так:
>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
> Ошибся  FastEthernet0/1 конечно же

Мужики, разобрался! Моя невнимательность всему виной :(

>>  deny   ip any 192.168.0.0 0.0.255.255

вот этой строкой я запретил доступ из сетки 192.168.34.0
Спасибо за участие!

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Нет маршрутизации на cisco 1841"  +/
Сообщение от uncle_grin email(ok) on 16-Дек-17, 22:44 

> Если задаете маршрут по умолчанию то делается это так:
> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

и это тоже применил. Спасибо!

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Нет маршрутизации на cisco 1841"  +/
Сообщение от fantom (??) on 17-Дек-17, 16:42 
>> Если задаете маршрут по умолчанию то делается это так:
>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
> и это тоже применил. Спасибо!

А зря. Для езернет именно это и не рекомендовано.

ip route 0.0.0.0 0.0.0.0 <next-hop ip>
рекомендуется

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Нет маршрутизации на cisco 1841"  +/
Сообщение от uncle_grin email(ok) on 17-Дек-17, 17:02 
>>> Если задаете маршрут по умолчанию то делается это так:
>>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
>> и это тоже применил. Спасибо!
> А зря. Для езернет именно это и не рекомендовано.
> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
> рекомендуется

что такое <next-hop ip> ? Шлюз провайдера?

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Нет маршрутизации на cisco 1841"  +/
Сообщение от zanswer CCNA RS and S on 17-Дек-17, 19:42 
>>>> Если задаете маршрут по умолчанию то делается это так:
>>>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
>>> и это тоже применил. Спасибо!
>> А зря. Для езернет именно это и не рекомендовано.
>> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
>> рекомендуется
> что такое <next-hop ip> ? Шлюз провайдера?

Любой адрес следующего перехода, в данном случая адрес шлюза провайдера.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Нет маршрутизации на cisco 1841"  +/
Сообщение от Serb on 19-Дек-17, 08:11 
>>> Если задаете маршрут по умолчанию то делается это так:
>>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
>> и это тоже применил. Спасибо!
> А зря. Для езернет именно это и не рекомендовано.
> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
> рекомендуется

Это вообще для всех multi access сетей недопустимо . Гнать из профессии за такие маршруты :)

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "Нет маршрутизации на cisco 1841"  +/
Сообщение от zanswer CCNA RS and S on 19-Дек-17, 10:05 
>>>> Если задаете маршрут по умолчанию то делается это так:
>>>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
>>> и это тоже применил. Спасибо!
>> А зря. Для езернет именно это и не рекомендовано.
>> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
>> рекомендуется
> Это вообще для всех multi access сетей недопустимо . Гнать из профессии
> за такие маршруты :)

Вы слишком категоричны насчёт недопустимости использования напрямую подключённых маршрутов для сред с множественным доступом. Это вполне может быть допустимо в ряде специфичных случаев, особенно для Ethernet сегментов, но в общем случае этого лучше избегать.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Нет маршрутизации на cisco 1841"  +/
Сообщение от fantom (??) on 19-Дек-17, 16:00 
>>>> Если задаете маршрут по умолчанию то делается это так:
>>>> ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
>>> и это тоже применил. Спасибо!
>> А зря. Для езернет именно это и не рекомендовано.
>> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
>> рекомендуется
> Это вообще для всех multi access сетей недопустимо . Гнать из профессии
> за такие маршруты :)

Ну почему же,
если у вас хосты с полной реализацией ICMP, вам начхать на джиттер, у вас 10-ти кратный запас по производительности и прорва времени на траблжуттинг...
То почему бы и не нет
;)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "Нет маршрутизации на cisco 1841"  +/
Сообщение от yuri (??) on 19-Дек-17, 21:54 
>[оверквотинг удален]
>>> ip route 0.0.0.0 0.0.0.0 <next-hop ip>
>>> рекомендуется
>> Это вообще для всех multi access сетей недопустимо . Гнать из профессии
>> за такие маршруты :)
> Ну почему же,
>  если у вас хосты с полной реализацией ICMP, вам начхать на
> джиттер, у вас 10-ти кратный запас по производительности и прорва времени
> на траблжуттинг...
> То почему бы и не нет
> ;)

А с чем это связанно? Что почитать на эту тему можно?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Нет маршрутизации на cisco 1841"  +/
Сообщение от zanswer CCNA RS and S on 20-Дек-17, 08:03 
>[оверквотинг удален]
>>>> рекомендуется
>>> Это вообще для всех multi access сетей недопустимо . Гнать из профессии
>>> за такие маршруты :)
>> Ну почему же,
>>  если у вас хосты с полной реализацией ICMP, вам начхать на
>> джиттер, у вас 10-ти кратный запас по производительности и прорва времени
>> на траблжуттинг...
>> То почему бы и не нет
>> ;)
> А с чем это связанно? Что почитать на эту тему можно?

С связано это с тем фактом, что в среде с множественным доступом, в отличие от сред точка-точка, в одном сегменте могут быть одновременно более двух устройств.

А значит требуется протокол способный выполнить преобразование сетевых адресов в канальные (ARP в Ethernet), или наоборот (inverse ARP/NHRP в Frame-Relay/ATM), зависит от типа канального протокола.

Так вот суть проблемы в том, что такое преобразование будет выполняться для каждого адреса назначения, для которого в ARP/ND кэше нет соответствующей записи.

Но, такие устройства физически находятся за пределами нашего сегмента, а значит возникает дилемма, кто же нам ответит на запрос? Например шлюз с поддержкой Proxy ARP/ND, а если такового нет, то вообще никто не ответит.

Но, даже получив ответ, мы столкнёмся с тем, что наша таблица кэша канальных адресов, станет не прилично большой, возрастёт нагрузка на CPU, поскольку такие протоколы относятся к группе протоколов управления, они выполняются на CPU, процессора маршрцтизацит. Увеличится общее время требуемое на первичную отправку пакетов, поскольку ранее достаточно было всего один раз выполнить запрос канального адреса нашего адреса следующего перехода, то теперь мы выполняем такой запрос для каждого адреса назначения. Увеличится и количество служебных пакетов, которые к слову могут быть ещё и широковещательными, что будет создавать лишнюю паразитную нагрузку на всё узлы нашего широковещательного домена.

Описание данной проблемы специалистом Cisco TAC:

“Static Route to Broadcast Interface

If you point a static route to a broadcast interface, the route is inserted into the routing table only when the broadcast interface is active. This configuration is not recommended because when the next hop of a static route points to an interface, the router considers each of the hosts within the range of the route to be directly connected through that interface. An example of such a static route is ip route 0.0.0.0 0.0.0.0 Ethernet0. With this type of configuration, a router performs Address Resolution Protocol (ARP) on the Ethernet for every destination that the router finds through the default route because the router considers all of these destinations as directly connected to Ethernet 0. This kind of static route, especially if it is used by many packets to many different destination subnets, can cause high processor utilization and a very large ARP cache (along with memory allocation failures). So, this kind of static route is not recommended.
When you specify the next hop address on a directly connected interface, it prevents the router from performing ARP for each destination address. An example is ip route 0.0.0.0 0.0.0.0 Ethernet0 192.168.1.1. You can specify the directly connected next hop address only, but this is not recommended for reasons that are described in this document. You do not need to specify the directly connected next hop address. You can specify the remote next hop address and the interface to which the remote next hop recurses.
If the interface with the next hop goes down and the next hop is reachable through a recursive route, you should specify both the next hop IP address and the alternate interface through which the next hop should be found. For example, ip route 0.0.0.0 0.0.0.0 Serial 3/3 192.168.20.1. This enables the static route installation to become more deterministic.”

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor