The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Приоритет траффика"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 10:20  (MSK)
Здравствуйте
имеется cisco1721 по eth к ней подключён samsung as500, в этом samsunge встроена плата преобразующая voice в IP.

call ---> as500 ---eth(LAN)---cisco1721--->internet
                       |
                       |
                   PC - PC- PC
каким образом на циске я могу установить наивысший приоритет исходящего voip траффика по отношению к web траффику?

Заранее всем благодарен.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Приоритет траффика" 
Сообщение от Nailer Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 11:18  (MSK)
>Здравствуйте
>имеется cisco1721 по eth к ней подключён samsung as500, в этом samsunge
>встроена плата преобразующая voice в IP.
>
>call ---> as500 ---eth(LAN)---cisco1721--->internet
>            
>          
>|
>            
>          
>|
>            
>       PC - PC- PC
>
>каким образом на циске я могу установить наивысший приоритет исходящего voip траффика
>по отношению к web траффику?
>
>Заранее всем благодарен.

У вас самсунг подключен напрямую к циске или вы свитч забыли показать? Если напрямую, то откуда берется веб-траффик?

Вы хотите только промаркировать VoIP-траффик или еще и приоритет ему обеспечить на этапе cisco1721--->internet? Несколько разные вещи.


  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 11:32  (MSK)
to Nailer
1. Sumsung подключён в свитч , sorry - забыл показать
2. Задача обеспечить наивысший приоритет voip траффику а этапе cisco1721--->internet
  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Приоритет траффика" 
Сообщение от Nailer Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 12:12  (MSK)
>to Nailer
>1. Sumsung подключён в свитч , sorry - забыл показать
>2. Задача обеспечить наивысший приоритет voip траффику а этапе cisco1721--->internet

Понятно.


Тогда:

1. Пишем acl, описывающий траффик, идущий _с_ АТС:

ip access-list extended Samsung
permit ip host xxx.xxx.xxx.xxx any

2. Пишем class-map:

class-map match-all VoIP
match access-group Samsung

3. Пишем policy-map, в котором проставляем приоритет для траффика VoIP и маркируем пакеты.

policy-map VoIP
class VoIP
  set ip precedence 5
  priority percent 50

class class-default
  fair-queue
  random-detect
  random-detect exponential-weighting-constant 5

4. Вешаем на интерфейс, смотрящий в инет

int xx0
service-policy output eth5-out

Вроде все.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 12:19  (MSK)
>>to Nailer
>>1. Sumsung подключён в свитч , sorry - забыл показать
>>2. Задача обеспечить наивысший приоритет voip траффику а этапе cisco1721--->internet
>
>Понятно.
>
>
>Тогда:
>
>1. Пишем acl, описывающий траффик, идущий _с_ АТС:
>
>ip access-list extended Samsung
> permit ip host xxx.xxx.xxx.xxx any
>
>2. Пишем class-map:
>
>class-map match-all VoIP
> match access-group Samsung
>
>3. Пишем policy-map, в котором проставляем приоритет для траффика VoIP и маркируем
>пакеты.
>
>policy-map VoIP
> class VoIP
>  set ip precedence 5
>  priority percent 50
>
> class class-default
>  fair-queue
>  random-detect
>  random-detect exponential-weighting-constant 5
>
>4. Вешаем на интерфейс, смотрящий в инет
>
>int xx0
> service-policy output eth5-out
>
>Вроде все.


Пасиба большое, ....попробую

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 12:40  (MSK)
>>>to Nailer
>>>1. Sumsung подключён в свитч , sorry - забыл показать
>>>2. Задача обеспечить наивысший приоритет voip траффику а этапе cisco1721--->internet
>>
>>Понятно.
>>
>>
>>Тогда:
>>
>>1. Пишем acl, описывающий траффик, идущий _с_ АТС:
>>
>>ip access-list extended Samsung
>> permit ip host xxx.xxx.xxx.xxx any
>>
>>2. Пишем class-map:
>>
>>class-map match-all VoIP
>> match access-group Samsung
>>
>>3. Пишем policy-map, в котором проставляем приоритет для траффика VoIP и маркируем
>>пакеты.
>>
>>policy-map VoIP
>> class VoIP
>>  set ip precedence 5
>>  priority percent 50
>>
>> class class-default
>>  fair-queue
>>  random-detect
>>  random-detect exponential-weighting-constant 5
>>
>>4. Вешаем на интерфейс, смотрящий в инет
>>
>>int xx0
>> service-policy output eth5-out
>>
>>Вроде все.
>
>
>Пасиба большое, ....попробую

to Nailer

ещё один вопрос....когда вешаем на исходящий int ...
service-policy output eth5-out
.....eth5-out  - это что такое? я так понимаю что здесьдолжно быть   VOIP ... или я не прав?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 12:21  (MSK)
У меня один вопрос - а 50% от чего?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Приоритет траффика" 
Сообщение от Nailer Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 12:31  (MSK)
>У меня один вопрос - а 50% от чего?

От ширины выходного интерфейса. Можно задать четко в килобитах, так наверное даже лучше..

Мдя, забыл - в конфиге интерфейса не забудьте bandwith указать правильно, особенно если у вас там какой-нибудь Eth->E1 конвертер стоит, до которого 100 мегабит, а за которым - 512К..


  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 12:44  (MSK)
>Мдя, забыл - в конфиге интерфейса не забудьте bandwith указать правильно, особенно если у вас там какой-нибудь Eth->E1 конвертер стоит, до которого 100 мегабит, а за которым - 512К..

Вот так то лучше! ;)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:09  (MSK)
Когда я привязываю service-police  к субинтерфейсу  Комнада проглатывается но при просмотре конфига не видно
  Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:22  (MSK)
sh run int покажите для основного и саба.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:31  (MSK)
interface FastEthernet0/0.19
bandwidth 256000
encapsulation isl 19
ip address .... 255.255.255.248
ip access-group 195 in
no ip redirects
no ip unreachables
no ip directed-broadcast
ip accounting output-packets
ip nat outside
ip policy route-map 19


class-map VoIP
  match access-group 119
!
!
policy-map VoIP
  class class-default
   bandwidth 0
   random-detect
   random-detect exponential-weighting-constant 5
  class VoIP
   bandwidth 192000
!

interface FastEthernet0/0
no ip address
no ip redirects
no ip unreachables
no ip directed-broadcast
no ip proxy-arp
ip route-cache flow
no ip route-cache cef
no ip mroute-cache
speed 100
full-duplex
no cdp enable

Cisco 2621

  Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:34  (MSK)
Первое что бросается в глаза это bandwidth 256000.
Ведь BW у нас в килобитах меряется.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:41  (MSK)
Это я перегнул
  Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:46  (MSK)
это не повлияло, все равно не видно service-police
  Рекомендовать в FAQ | Cообщить модератору | Наверх

15. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 14:52  (MSK)
P.S. В  
class VoIP
bandwidth 192000
тоже исправить!

Вот это мне совсем не понятно:
class class-default
   bandwidth 0

А что показывает sh poli int?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

16. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 15:03  (MSK)
исправил, ничего не показывает .. пусто
  Рекомендовать в FAQ | Cообщить модератору | Наверх

17. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 15:14  (MSK)
А такого не писали CBWFQ : Not supported on subinterfaces?
Может не явно - в логе может появлялось?

FYI: http://www.cisco.com/warp/public/105/qos_subint.html

  Рекомендовать в FAQ | Cообщить модератору | Наверх

18. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 15:16  (MSK)
Да я и к интерфейсу пробовал подвязать, то же самое, не ругается  глотает и не видно
  Рекомендовать в FAQ | Cообщить модератору | Наверх

19. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 15:21  (MSK)
Center(config)#policy-map VoIP
Center(config-pmap)#class VoIP
Center(config-pmap-c)#?
QoS policy-map class configuration commands:
  bandwidth      Bandwidth
  default        Set a command to its defaults
  exit           Exit from QoS class action configuration mode
  no             Negate a command or set its defaults
  queue-limit    Queue Max Threshold for Tail Drop
  random-detect  Enable Random Early Detection as drop policy
  <cr>

нет shape как в руководстве

  Рекомендовать в FAQ | Cообщить модератору | Наверх

20. "Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 15:30  (MSK)
>Center(config)#policy-map VoIP
>Center(config-pmap)#class VoIP
>Center(config-pmap-c)#?
>QoS policy-map class configuration commands:
>  bandwidth      Bandwidth
>  default        Set a
>command to its defaults
>  exit          
> Exit from QoS class action configuration mode
>  no          
>   Negate a command or set its defaults
>  queue-limit    Queue Max Threshold for Tail Drop
>
>  random-detect  Enable Random Early Detection as drop policy
>  <cr>
>
>нет shape как в руководстве

Cisco 2610 IOS c2600-i-mz.122-19a.bin
Тут share вроде имеется

Router(config)#policy-map voip
Router(config-pmap)#class voip
Router(config-pmap-c)#?
QoS policy-map class configuration commands:
  bandwidth       Bandwidth
  exit            Exit from QoS class action configuration mode
  no              Negate or set default values of a command
  priority        Strict Scheduling Priority for this Class
  queue-limit     Queue Max Threshold for Tail Drop
  random-detect   Enable Random Early Detection as drop policy
  service-policy  Configure QoS Service Policy
  shape           Traffic Shaping
  <cr>
  police          Police
  set             Set QoS values

  Рекомендовать в FAQ | Cообщить модератору | Наверх

21. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 15:57  (MSK)
у меня не столь молодая IOS
  Рекомендовать в FAQ | Cообщить модератору | Наверх

22. "Приоритет траффика" 
Сообщение от WIC Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 18-Янв-05, 15:59  (MSK)
>у меня не столь молодая IOS


ну я думаю вам стоит обновить IOS

  Рекомендовать в FAQ | Cообщить модератору | Наверх

23. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 16:09  (MSK)
ну да и докупить памяти
  Рекомендовать в FAQ | Cообщить модератору | Наверх

24. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 18-Янв-05, 16:22  (MSK)
Почти всегда можно подобрать нужный IOS без апгрейда памяти.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

25. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:00  (MSK)
Значит у меня никак, хотя не ругается не на что
  Рекомендовать в FAQ | Cообщить модератору | Наверх

26. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:02  (MSK)
Что?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

27. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:44  (MSK)
Даю в конфигурации интерфейса команду service-policy
Команда проглатывается и все.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

28. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:49  (MSK)
>Даю в конфигурации интерфейса команду service-policy
>Команда проглатывается и все.

Так мы уже выяснили что Вам ай-о-эс надо менять!

  Рекомендовать в FAQ | Cообщить модератору | Наверх

29. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:52  (MSK)
Так если не поддерживал бы IOS он бы ругался не давал бы class-map policy-map заводить, ругался бы на service-policy, так не ругается же!
  Рекомендовать в FAQ | Cообщить модератору | Наверх

30. "Приоритет траффика" 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 16:58  (MSK)
>Так если не поддерживал бы IOS он бы ругался не давал бы
>class-map policy-map заводить, ругался бы на service-policy, так не ругается же!
Ну батенька если считать что все что дает cisco ввести в себя(о как загнул) то поддерживается, а остальное нет - то так далеко мы не уйдем.
У индусов, как говорят с вест тасман драйв, трава бывает разной!
  Рекомендовать в FAQ | Cообщить модератору | Наверх

31. "Приоритет траффика" 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Янв-05, 17:06  (MSK)
Интересно зачем в подсказках даны доступные опции?
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру