The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Не хватает памяти Cisco 2821"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 20-Мрт-19, 23:04 
Доброй ночи. Моя проблема в том что я начинаю уже тупить с с маршрутизатором за одно. Уже 2 дня пропадает интернет. После перезагрузки маршрутизатора худо бедно работает. Но хватает часа на 2. Вываливает ошибки что не хватает памяти. Я начинающий сисадмин. Сильно не печальтесь уж. Направьте на путь куда копать проблему. Есть подозрение что организовано что то топа DDoS
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Не хватает памяти Cisco 2821"  +/
Сообщение от ShyLion (ok), 21-Мрт-19, 07:06 
> Доброй ночи. Моя проблема в том что я начинаю уже тупить с
> с маршрутизатором за одно. Уже 2 дня пропадает интернет. После перезагрузки
> маршрутизатора худо бедно работает. Но хватает часа на 2. Вываливает ошибки
> что не хватает памяти. Я начинающий сисадмин. Сильно не печальтесь уж.
> Направьте на путь куда копать проблему. Есть подозрение что организовано что
> то топа DDoS

Штатные телепаты в отпуске.

show ver
show run

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 08:32 
>> Доброй ночи. Моя проблема в том что я начинаю уже тупить с
>> с маршрутизатором за одно. Уже 2 дня пропадает интернет. После перезагрузки
>> маршрутизатора худо бедно работает. Но хватает часа на 2. Вываливает ошибки
>> что не хватает памяти. Я начинающий сисадмин. Сильно не печальтесь уж.
>> Направьте на путь куда копать проблему. Есть подозрение что организовано что
>> то топа DDoS
> Штатные телепаты в отпуске.
> show ver
> show run

2821#show ver
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(18), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Fri 30-Nov-07 16:36 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

2821 uptime is 2 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-advipservicesk9-mz.124-18.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

2821 (revision 53.50) with 249856K/12288K bytes of memory.
Processor board ID FCZ110570HN
2 Gigabit Ethernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102


2821#show run
Building configuration...

Current configuration : 5633 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2821
!
boot-start-marker
boot system flash:c2800nm-advipservicesk9-mz.124-18.bin
boot-end-marker
!
logging buffered 52000 debugging
enable secret 5 ******
!
no aaa new-model
!
!
ip cef
!
!
ip domain name yourdomain.com
ip name-server 192.168.0.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 0 password
!
!
!
!
crypto isakmp policy 2
authentication pre-share
!
crypto isakmp policy 3
authentication pre-share
group 2
crypto isakmp key 01234 address 91.135.202.82
crypto isakmp key 01234 address 89.107.97.68
crypto isakmp invalid-spi-recovery
!
!
crypto ipsec transform-set myset1 esp-null esp-md5-hmac
!
crypto map shar 11 ipsec-isakmp
set peer 89.107.97.68
set transform-set myset1
match address 102
!
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 123.456.789.10 255.255.255.252
ip nat outside
ip nat enable
ip virtual-reassembly
duplex auto
speed 100
crypto map shar
!
interface GigabitEthernet0/1
ip address 192.168.21.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 123.456.789.11
ip route 987.654.321.0 255.255.255.240 192.168.21.2
ip route 192.168.0.0 255.255.0.0 192.168.21.2
ip route 192.168.1.0 255.255.255.0 192.168.21.2 permanent
!
!
ip http server
ip http access-class 23
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat pool NAT_COMSTAR 123.456.789.10 123.456.789.10 prefix-length 1
ip nat source list 108 pool NAT_COMSTAR overload
ip nat source route-map nonat pool NAT_COMSTAR overload
!
access-list 23 permit 91.135.202.82
access-list 23 permit 2.72.171.142
access-list 23 permit 83.146.115.28
access-list 23 permit 91.185.6.10
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 23 permit 212.30.182.0 0.0.0.255
access-list 23 permit 2.72.0.0 0.0.255.255
access-list 23 permit 2.73.0.0 0.0.255.255
access-list 23 permit 95.71.0.0 0.0.255.255
access-list 23 permit 178.44.0.0 0.0.255.255
access-list 23 permit 85.192.0.0 0.0.255.255
access-list 102 permit ip 192.168.21.0 0.0.0.255 172.17.0.0 0.0.255.255
access-list 102 permit ip 192.168.21.0 0.0.0.255 192.168.100.0 0.0.0.255
access-list 108 deny   ip 192.168.21.0 0.0.0.255 172.17.0.0 0.0.255.255
access-list 108 deny   ip 192.168.21.0 0.0.0.255 192.168.100.0 0.0.0.255
access-list 108 permit ip host 192.168.0.208 any
access-list 108 permit ip host 192.168.0.201 any


!
route-map nonat permit 10
match ip address 108
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
escape-character 3
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 55 0
password
login local
transport input telnet
escape-character 3
line vty 5 1180
access-class 23 in
password
login
transport input telnet
escape-character 3
!
scheduler allocate 20000 1000
!
end

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 10:07 
Ну а теперь логи...
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 10:38 
> Ну а теперь логи...

а вот логи то и не настроены...
последнее что есть
*Mar 21 06:59:46.747: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State change                                 d to: Initialized
*Mar 21 06:59:46.751: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State change                                 d to: Enabled
*Mar 21 06:59:47.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0                                 , changed state to up
*Mar 21 06:59:47.739: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed stat                                 e to up
*Mar 21 06:59:47.743: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed stat                                 e to up
*Mar 21 06:59:48.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth                                 ernet0/0, changed state to up
*Mar 21 06:59:49.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth                                 ernet0/1, changed state to up
*Mar 21 06:59:50.435: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan                                 ged state to up
*Mar 21 06:59:51.035: %SYS-5-CONFIG_I: Configured from memory by console
*Mar 21 06:59:51.391: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(18),                                  RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Fri 30-Nov-07 16:36 by prod_rel_team
*Mar 21 06:59:51.395: %SNMP-5-COLDSTART: SNMP agent on host 2821 is underg                                 oing a cold start
*Mar 21 06:59:51.395: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 06:59:51.395: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 06:59:51.811: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Mar 21 06:59:51.811: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON
*Mar 21 07:00:21.399: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:00:21.399: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:00:51.399: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:00:51.399: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:01:21.415: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:01:21.415: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:01:51.419: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:01:51.419: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:02:21.431: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:02:21.431: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:02:51.435: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:02:51.435: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:03:21.455: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 07:03:21.455: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 07:03:51.455: %ENVMON-3-FAN_FAILED: Fan 1 not rotating

счас настраиваю zabbix как раз таки на снятие логов.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Не хватает памяти Cisco 2821"  +/
Сообщение от eek (ok), 21-Мрт-19, 10:53 
Коллега, в этих логах про память ничего нет.

А вот про пропеллеры которые не крутятся очень даже...

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

12. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:14 
>[оверквотинг удален]
> *Mar 21 07:01:21.415: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
> *Mar 21 07:01:51.419: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
> *Mar 21 07:01:51.419: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
> *Mar 21 07:02:21.431: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
> *Mar 21 07:02:21.431: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
> *Mar 21 07:02:51.435: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
> *Mar 21 07:02:51.435: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
> *Mar 21 07:03:21.455: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
> *Mar 21 07:03:21.455: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
> *Mar 21 07:03:51.455: %ENVMON-3-FAN_FAILED: Fan 1 not rotating

Этого - достаточно. Более чем. Она у тебя тупо перегревается, ибо 2 пропеллера из трех не работают
Скажи ей sh env all и ужаснись результатам...

> счас настраиваю zabbix как раз таки на снятие логов.

Начни с простого - https://loganalyzer.adiscon.com
Или просто возми любую машину с линаксом и лей на нее логи сислогом...

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

4. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 10:10 
Да и IOS древний как окаменелое г-но мамомнта... Яб обновил. Самый последний правда не влезет на эту флешку, но поновей все же поставить можно.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Не хватает памяти Cisco 2821"  +/
Сообщение от fantom (??), 21-Мрт-19, 10:12 
>[оверквотинг удален]
> line vty 5 1180
>  access-class 23 in
>  password
>  login
>  transport input telnet
>  escape-character 3
> !
> scheduler allocate 20000 1000
> !
> end

Вероятнее всего NAT ужирает всю память, как вариант:
1. сменить IOS на поновее.
2. выставить ограничения на количество NAT трансляций в таблице.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

7. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 10:42 
>[оверквотинг удален]
>>  login
>>  transport input telnet
>>  escape-character 3
>> !
>> scheduler allocate 20000 1000
>> !
>> end
> Вероятнее всего NAT ужирает всю память, как вариант:
> 1. сменить IOS на поновее.
> 2. выставить ограничения на количество NAT трансляций в таблице.

самое обидное что нет ни бэкапа ни сохраненной конфы с него. а еще на удивление он один на всю конторку...то есть мне надо как то сначала подготовить другой маршрутизатор а потом шить этот..

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Не хватает памяти Cisco 2821"  +/
Сообщение от fantom (??), 21-Мрт-19, 11:04 
>[оверквотинг удален]
>>> !
>>> scheduler allocate 20000 1000
>>> !
>>> end
>> Вероятнее всего NAT ужирает всю память, как вариант:
>> 1. сменить IOS на поновее.
>> 2. выставить ограничения на количество NAT трансляций в таблице.
> самое обидное что нет ни бэкапа ни сохраненной конфы с него. а
> еще на удивление он один на всю конторку...то есть мне надо
> как то сначала подготовить другой маршрутизатор а потом шить этот..

??? заливаете IOS, рестартуете и УСЕ! накой вам второй маршрутизатор-то????
Конфу сохранить - ну если не хватает фантазии обратится к руководствам "для кипятильников" в инете, то тут на форум вы же как-то этот самый конфиг выложили! :) вот и воспользуйтесь уже имеющимся опытом....
Выставить ограничение - это вообще ТУПО 2 КОМАНДЫ ВБИТЬ!!!! Если вы и этого не умеете, то
"Я начинающий сисадмин" стоит переформулировать в "Я новорожденный сисадмин" или "Я только что зачатый сисадмин"

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 11:09 
>[оверквотинг удален]
>> еще на удивление он один на всю конторку...то есть мне надо
>> как то сначала подготовить другой маршрутизатор а потом шить этот..
> ??? заливаете IOS, рестартуете и УСЕ! накой вам второй маршрутизатор-то????
> Конфу сохранить - ну если не хватает фантазии обратится к руководствам "для
> кипятильников" в инете, то тут на форум вы же как-то этот
> самый конфиг выложили! :) вот и воспользуйтесь уже имеющимся опытом....
> Выставить ограничение - это вообще ТУПО 2 КОМАНДЫ ВБИТЬ!!!! Если вы и
> этого не умеете, то
> "Я начинающий сисадмин" стоит переформулировать в "Я новорожденный сисадмин" или "Я только
> что зачатый сисадмин"

еще момент, обновляться до самой новой? или есть более стабильные версии? хотя у cisco наверно все стабильные

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 11:18 
>[оверквотинг удален]
>> ??? заливаете IOS, рестартуете и УСЕ! накой вам второй маршрутизатор-то????
>> Конфу сохранить - ну если не хватает фантазии обратится к руководствам "для
>> кипятильников" в инете, то тут на форум вы же как-то этот
>> самый конфиг выложили! :) вот и воспользуйтесь уже имеющимся опытом....
>> Выставить ограничение - это вообще ТУПО 2 КОМАНДЫ ВБИТЬ!!!! Если вы и
>> этого не умеете, то
>> "Я начинающий сисадмин" стоит переформулировать в "Я новорожденный сисадмин" или "Я только
>> что зачатый сисадмин"
> еще момент, обновляться до самой новой? или есть более стабильные версии? хотя
> у cisco наверно все стабильные

Pool: Processor  Free: 473048  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x4009A648 0x4009F254 0x400A066C 0x400AA66C 0x400A9DB8 0x400A9F44 0x42196BE4 0x42196BC8
*Mar 21 06:20:10.063: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:20:21.651: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:20:31.683: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:20:38.311: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 06:20:38.315: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 06:20:40.831: %SYS-2-MALLOCFAIL: Memory allocation of 848 bytes failed from 0x400AA664, alignment 8
Pool: Processor  Free: 529088  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x4009A648 0x4009F254 0x400A066C 0x400AA66C 0x400A9DB8 0x400A9F44 0x42196BE4 0x42196BC8
*Mar 21 06:20:41.883: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:20:51.891: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:21:01.935: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:21:08.331: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 06:21:08.331: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 06:21:32.455: %SYS-2-MALLOCFAIL: Memory allocation of 848 bytes failed from 0x400AA664, alignment 8
Pool: Processor  Free: 473048  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x4009A648 0x4009F254 0x400A066C 0x400AA66C 0x400A9DB8 0x400A9F44 0x42196BE4 0x42196BC8
*Mar 21 06:21:32.455: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:21:38.331: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 06:21:38.331: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 06:21:42.499: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:21:55.739: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:22:02.455: %SYS-2-MALLOCFAIL: Memory allocation of 848 bytes failed from 0x400AA664, alignment 8
Pool: Processor  Free: 473048  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "IP Input", ipl= 0, pid= 78 -Traceback= 0x41182E94 0x4009A648 0x4009F254 0x400A066C 0x400AA66C 0x400AA0AC 0x400ABBC8 0x400A9D10 0x42ABD520 0x4182586C 0x41825E18 0x417F8F6C 0x41827EC4 0x4182869C 0x41653BC0 0x416561BC
*Mar 21 06:22:06.183: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8
*Mar 21 06:22:08.335: %ENVMON-3-FAN_FAILED: Fan 1 not rotating
*Mar 21 06:22:08.335: %ENVMON-3-FAN_FAILED: Fan 3 not rotating
*Mar 21 06:22:16.183: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for NAT-NVI VRF ta. No memory available -Process= "Chunk Manager", ipl= 3, pid= 1 -Traceback= 0x41182E94 0x400A9F88 0x42196BE4 0x42196BC8

вот что говорит когда ничего не работает, это при подключение к ней с помощью консоли

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

14. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:19 

> вот что говорит когда ничего не работает, это при подключение к ней
> с помощью консоли

Перегрев - разбирай и смазывай пропеллеры. Или лучше замени, насколько я помню там стандартные от писюка 80мм лезут. Только не помню на 3 или на 4-е пина надо.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

18. "Не хватает памяти Cisco 2821"  +/
Сообщение от asser (?), 21-Мрт-19, 13:43 
> *Mar 21 06:20:40.831: %SYS-2-MALLOCFAIL: Memory allocation of 848 bytes failed from 0x400AA664,
> alignment 8
> Pool: Processor  Free: 529088  Cause: Memory fragmentation
> Alternate Pool: None  Free: 0  Cause: No Alternate pool

Недавно столкнулись с такой проблемой на нескольких 2821, помогло обновление до c2800nm-advipservicesk9-mz.124-25g.bin (размер 36.3 МБ)

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

15. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:23 
> еще момент, обновляться до самой новой? или есть более стабильные версии? хотя
> у cisco наверно все стабильные

Самая новая не влезет на твою фешку - там нужно минимум 128Мб, а у тебя 64Мб. По идее туда влезет почти любой CompactFlash... но не любой, совместимо примерно 20%. Проверяется только эксперементально. Большей емкости (до 2Гб) - тоже влезет, но шансы еще меньше.

У меня вроде последняя IOS из тех что влезает на 64Мб - System image file is "flash:c2800nm-advipservicesk9-mz.151-2.T2.bin"

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

16. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:25 
>> еще момент, обновляться до самой новой? или есть более стабильные версии? хотя
>> у cisco наверно все стабильные
> Самая новая не влезет на твою фешку - там нужно минимум 128Мб,
> а у тебя 64Мб. По идее туда влезет почти любой CompactFlash...
> но не любой, совместимо примерно 20%. Проверяется только эксперементально. Большей емкости
> (до 2Гб) - тоже влезет, но шансы еще меньше.
> У меня вроде последняя IOS из тех что влезает на 64Мб -
> System image file is "flash:c2800nm-advipservicesk9-mz.151-2.T2.bin"

Ах да - прежде чем проверять флешки на совместимость, обнови ROM: System Bootstrap, который, проблемы с флешками нередко в нем - так что лучше если он будет самый свежий.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

13. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:18 
.
> самое обидное что нет ни бэкапа ни сохраненной конфы с него. а
> еще на удивление он один на всю конторку...то есть мне надо
> как то сначала подготовить другой маршрутизатор а потом шить этот..

copy run tftp:<твой тфтп-сервер> и готов бекап конфига. А вообще нажимай ? в командной строке - получишь подсказку что вводить дальше.

Другой маршрутизатор не нужен - так же по тфтп заливаешь bin-файл с IOS заместо своего и перегружаешь маршрутизатор. Вот и все обновление.
Где взять? На рутрекере есть соответствующая тема :)

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

19. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 14:25 
> .
>> самое обидное что нет ни бэкапа ни сохраненной конфы с него. а
>> еще на удивление он один на всю конторку...то есть мне надо
>> как то сначала подготовить другой маршрутизатор а потом шить этот..
> copy run tftp:<твой тфтп-сервер> и готов бекап конфига. А вообще нажимай ?
> в командной строке - получишь подсказку что вводить дальше.
> Другой маршрутизатор не нужен - так же по тфтп заливаешь bin-файл с
> IOS заместо своего и перегружаешь маршрутизатор. Вот и все обновление.
> Где взять? На рутрекере есть соответствующая тема :)

да бэкап сделал. думал залить сразу прошивку, не тут то было, придется удалять все старое, свободно всего 1,5 мб

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

17. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 13:34 

> Вероятнее всего NAT ужирает всю память

Как выяснилось - банальный перегрев похоже. Хотя сначала я думал на битое ОЗУ... :)

NAT всю память на кошке выжрать не может принципиально - там всего по 65к трансляций мах. на один IP, даже теоретически, а памяти у нее... много... :)
Я пытался - не получилось, там надо минимум десяток IP и не одну тысячу рабочих станций использовать, чтоб засрать всю память NAT-ом...
Единственное что заставляет тебя беспокоится об ОЗУ на кошке - это full BGP view и желательно - не один. :)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

20. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 16:03 
>> Вероятнее всего NAT ужирает всю память
> Как выяснилось - банальный перегрев похоже. Хотя сначала я думал на битое
> ОЗУ... :)
> NAT всю память на кошке выжрать не может принципиально - там всего
> по 65к трансляций мах. на один IP, даже теоретически, а памяти
> у нее... много... :)
> Я пытался - не получилось, там надо минимум десяток IP и не
> одну тысячу рабочих станций использовать, чтоб засрать всю память NAT-ом...
> Единственное что заставляет тебя беспокоится об ОЗУ на кошке - это full
> BGP view и желательно - не один. :)

по-моему дело в другом. у меня почти все хосты в сети посылают запрос на 192.XXX.XXX.255
прокся говорит что пытается отправить пакет на 173.194.73.132. он пустой. на порт udp. также прокся словила 173.194.73.132/1.txt 173.194.73.132/2.txt и так далее. антивирь молчит. вот у меня и нагружает сеть эта херата
как теперь его выловить

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

21. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 21-Мрт-19, 16:10 
>[оверквотинг удален]
>> Я пытался - не получилось, там надо минимум десяток IP и не
>> одну тысячу рабочих станций использовать, чтоб засрать всю память NAT-ом...
>> Единственное что заставляет тебя беспокоится об ОЗУ на кошке - это full
>> BGP view и желательно - не один. :)
> по-моему дело в другом. у меня почти все хосты в сети посылают
> запрос на 192.XXX.XXX.255
> прокся говорит что пытается отправить пакет на 173.194.73.132. он пустой. на порт
> udp. также прокся словила 173.194.73.132/1.txt 173.194.73.132/2.txt и так далее. антивирь
> молчит. вот у меня и нагружает сеть эта херата
> как теперь его выловить

http://66.117.6.174/ver.txt
и вот такие херовины еще ловит

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "Не хватает памяти Cisco 2821"  +/
Сообщение от 1 (??), 21-Мрт-19, 16:44 
ну это вроде адреса гугла, но все равно можно попробовать зароутить в ноль:

ip route 173.194.73.132 255.255.255.255 Null0

ip route 66.117.6.174 255.255.255.255 Null0

и посмотреть что будет дальше

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

23. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 21-Мрт-19, 16:54 
> ну это вроде адреса гугла, но все равно можно попробовать зароутить в
> ноль:
> ip route 173.194.73.132 255.255.255.255 Null0
> ip route 66.117.6.174 255.255.255.255 Null0
> и посмотреть что будет дальше

Сначала - просто посмотри sh env all перед зависанием. Я все-таки думаю что проблема - в 2х неработающих вентиляторах из 3х, и как следствии - в вульгарном перегреве.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

24. "Не хватает памяти Cisco 2821"  +/
Сообщение от fantom (??), 22-Мрт-19, 11:35 
>> Вероятнее всего NAT ужирает всю память
> Как выяснилось - банальный перегрев похоже. Хотя сначала я думал на битое
> ОЗУ... :)
> NAT всю память на кошке выжрать не может принципиально - там всего
> по 65к трансляций мах. на один IP, даже теоретически, а памяти
> у нее... много... :)
> Я пытался - не получилось, там надо минимум десяток IP и не
> одну тысячу рабочих станций использовать, чтоб засрать всю память NAT-ом...
> Единственное что заставляет тебя беспокоится об ОЗУ на кошке - это full
> BGP view и желательно - не один. :)

Ну не 65к, а таки 131к :) на один адрес. Про UDP не забываем.
При достаточной интенсивности появления новых трансляций все очень даже неплохо сжирается, и в dead падает очень даже шустро, хотя и очень IOS-озависимо.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

25. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 22-Мрт-19, 15:29 
Меня больше всего интересует - помогла ли топикпастру замена вентиляторов? :)

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

26. "Не хватает памяти Cisco 2821"  +/
Сообщение от 1 (??), 22-Мрт-19, 16:30 
да, что-то он молчит, а таки интересно...

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

28. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 25-Мрт-19, 05:42 
> да, что-то он молчит, а таки интересно..

сегодня только буду их менять.... и вообще вскрывать за 12 лет первый раз. что то боязно трогать все это.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

32. "Не хватает памяти Cisco 2821"  +/
Сообщение от ShyLion (ok), 26-Мрт-19, 07:16 
>  ip nat enable

это лишнее и вероятно даже вредное, включает режим NAT NVI при котором nat inside/outside не нужен
т.е. у тебя одновременно включено два, взаимоисключающих режима NAT
NAT NVI нужен в особых случаях и не поддерживает некоторые ALG


interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 123.456.789.10 255.255.255.252
ip nat outside
interface GigabitEthernet0/1
ip address 192.168.21.1 255.255.255.0
ip nat inside
!
ip nat inside source list 108 pool NAT_COMSTAR overload

Конфиг привел обрезаный, так что назначение роутмапов непонятно

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

27. "Не хватает памяти Cisco 2821"  +/
Сообщение от Serb (?), 24-Мрт-19, 20:16 
> Доброй ночи. Моя проблема в том что я начинаю уже тупить с
> с маршрутизатором за одно. Уже 2 дня пропадает интернет. После перезагрузки
> маршрутизатора худо бедно работает. Но хватает часа на 2. Вываливает ошибки
> что не хватает памяти. Я начинающий сисадмин. Сильно не печальтесь уж.
> Направьте на путь куда копать проблему. Есть подозрение что организовано что
> то топа DDoS

Кроме вентиляторов , NAT конфигурация неправильная , зачем и то и NAT NVI и классический NAT на одних и Техе че интерфейсах . Это безобразие убрать срочно надо , на 12 iOS лучше использовать классический NAT (если nvi не нужен, а тут он не нужен ) , так как он более стабилен и работает быстрее

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

29. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 25-Мрт-19, 11:42 
вообщем снял, разобрал его, включил, все вентиляторы вращаются, со скрипом конечно но скорость приличная, подключил к консоли ошибок не выдает, подергал кулера, в итоге разобрал их промыл помазал, поставил обратно, скрип и шум пропал, ошибок пока нет, часа через 2 будет заметно что не так.

сегодня тестирую

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

30. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 25-Мрт-19, 17:59 

> сегодня тестирую

Ну расскажи по результатам - интересно же.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

31. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 25-Мрт-19, 23:13 
>> сегодня тестирую
> Ну расскажи по результатам - интересно же.

зависания и ошибки на кулера пропали. спасибо кто чего советовал.я конечно еще буду тестить.
также пропала ошибка соеденения по. телнету

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

33. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 26-Мрт-19, 13:24 
Ожидаемый результат... Но IOS поновей залей все же и конфиги поправь как советовали...

Кошка это очень мощная железка с одной стороны, с другой - она требует бережного отношения к ресурсам, вот такой парадокс...

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

34. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 26-Мрт-19, 15:43 
> Ожидаемый результат... Но IOS поновей залей все же и конфиги поправь как
> советовали...
> Кошка это очень мощная железка с одной стороны, с другой - она
> требует бережного отношения к ресурсам, вот такой парадокс...

так мне с конфигами предстоит долгий процесс.. ни одного влана нет, все в одной сети.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

35. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 27-Мрт-19, 09:39 
> Ожидаемый результат... Но IOS поновей залей все же и конфиги поправь как
> советовали...
> Кошка это очень мощная железка с одной стороны, с другой - она
> требует бережного отношения к ресурсам, вот такой парадокс...

ох тыж мать их

*Mar 25 19:45:26.489: %CRYPTO-4-RECVD_PKT_INV_SPI: decaps: rec'd IPSEC packet ha                                      s invalid spi for destaddr=xxx.xxx.xxx.xxx, prot=17, spi=0x30303030(808464432), s                                      rcaddr=185.142.236.35

*Mar 25 13:39:00.159: %CRYPTO-4-RECVD_PKT_INV_SPI: decaps: rec'd IPSEC packet ha                                      s invalid spi for destaddr=xxx.xxx.xxx.xxx, prot=17, spi=0x30303030(808464432), s                                      rcaddr=71.6.199.23

зачем так? кто то пытается проникнуть?

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

36. "Не хватает памяти Cisco 2821"  +/
Сообщение от Gunsfeel (ok), 27-Мрт-19, 09:42 
>[оверквотинг удален]
> *Mar 25 13:39:00.159: %CRYPTO-4-RECVD_PKT_INV_SPI: decaps: rec'd IPSEC packet ha    
>            
>            
>            
>  s invalid spi for destaddr=xxx.xxx.xxx.xxx, prot=17, spi=0x30303030(808464432), s  
>            
>            
>            
>   rcaddr=71.6.199.23
> зачем так? кто то пытается проникнуть?

*Mar 27 07:46:57.948: %IP_VFR-4-FRAG_TABLE_OVERFLOW: GigabitEthernet0/0: the fra                                      gment table has reached its maximum threshold 16
и вот еще

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

37. "Не хватает памяти Cisco 2821"  +/
Сообщение от ShyLion (ok), 28-Мрт-19, 07:10 
> зачем так? кто то пытается проникнуть?

В интернете постоянно кто-то пытается поиметь твои хосты, тычась на все известные дыры в ОС.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

38. "Не хватает памяти Cisco 2821"  +/
Сообщение от Pofigist (?), 28-Мрт-19, 10:09 
>> зачем так? кто то пытается проникнуть?
> В интернете постоянно кто-то пытается поиметь твои хосты, тычась на все известные
> дыры в ОС.

Именно. Поэтому можно начать танцевать от этой статьи - https://habr.com/ru/post/436280/

И вот тогда ты действительно познакомишься с нехваткой памяти на кошке... :)

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру