The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Как настроить WAN, если провайдер выдает динамический IP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 15-Сен-18, 10:04 
Собственно ситуация:
Провайдер, допустим севастопольский Севстар, выдает динамический адрес. При этом он периодически меняет адрес шлюза! Каждый раз руками прописывать шлюх надоело. Что делать? Что прописать?
Маршрутизатор 1841

interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.65.240.1
!

Подскажите, пожалуйста, я в тупик попал :(

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Аноним (1), 15-Сен-18, 11:06 
> Провайдер, допустим севастопольский Севстар, выдает динамический адрес. При этом он периодически
> меняет адрес шлюза! Каждый раз руками прописывать шлюх надоело. Что делать?

Менять невменяемого провайдера на нормального

> Что прописать?

Как адрес-то выдается? Какое подключение к прову? VPN? PPPoE?
Телепаты, как обычно, в отпусках....

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Аноним (1), 15-Сен-18, 11:09 
> Как адрес-то выдается? Какое подключение к прову? VPN? PPPoE?
> Телепаты, как обычно, в отпусках....

Пардон, не заметил

>> ip address dhcp

Значит, менять провайдера, бо провайдер - идиот.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

8. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от fantom (??), 15-Сен-18, 17:04 

> Значит, менять провайдера, бо провайдер - идиот.

Пойти учиться для начала...

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

9. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Аноним (1), 15-Сен-18, 19:12 

>> Значит, менять провайдера, бо провайдер - идиот.
> Пойти учиться для начала...

Угу, персоналу провайдера.
За десяток лет за время общения с наверное с полусотней телекомов еще ни разу не встречал конторы, который раздает адреса, гоняя клиентов из подсети в подсеть со сменой defaultroute. Даже в домолокалках такого бардака не встречал.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

12. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от fantom (??), 16-Сен-18, 14:14 
>>> Значит, менять провайдера, бо провайдер - идиот.
>> Пойти учиться для начала...
> Угу, персоналу провайдера.
> За десяток лет за время общения с наверное с полусотней телекомов еще
> ни разу не встречал конторы, который раздает адреса, гоняя клиентов из
> подсети в подсеть со сменой defaultroute. Даже в домолокалках такого бардака
> не встречал.

Вы и на дне марианской впадины никогда не бывали, но это не означает что дна у нее нет :)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

2. "Как настроить WAN, если провайдер выдает динамический IP"  +1 +/
Сообщение от k. d. (?), 15-Сен-18, 11:08 
>[оверквотинг удален]
>  ip nat outside
>  ip virtual-reassembly
>  duplex auto
>  speed auto
> !
> !
> ip forward-protocol nd
> ip route 0.0.0.0 0.0.0.0 100.65.240.1
> !
> Подскажите, пожалуйста, я в тупик попал :(

conf t
no ip route 0.0.0.0 0.0.0.0 100.65.240.1
ip route 0.0.0.0 0.0.0.0 dhcp
end
copy run start

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от eRIC (ok), 15-Сен-18, 12:18 
> conf t
> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
> ip route 0.0.0.0 0.0.0.0 dhcp
> end
> copy run start

+1

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от gfh1gfh1 (ok), 15-Сен-18, 14:18 
>> conf t
>> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
>> ip route 0.0.0.0 0.0.0.0 dhcp
>> end
>> copy run start
> +1

-1

ip route 0.0.0.0 0.0.0.0 FastEthernet4

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 15-Сен-18, 15:38 
>>> conf t
>>> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
>>> ip route 0.0.0.0 0.0.0.0 dhcp
>>> end
>>> copy run start
>> +1
> -1
> ip route 0.0.0.0 0.0.0.0 FastEthernet4

Это не работало, проверял

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "Как настроить WAN, если провайдер выдает динамический IP"  +1 +/
Сообщение от Andrey (??), 15-Сен-18, 19:41 
>>> conf t
>>> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
>>> ip route 0.0.0.0 0.0.0.0 dhcp
>>> end
>>> copy run start
>> +1
> -1
> ip route 0.0.0.0 0.0.0.0 FastEthernet4

Садись, два. К следующему уроку выучить отличие Ethernet сетей от P-t-P подключений.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

11. "Как настроить WAN, если провайдер выдает динамический IP"  +1 +/
Сообщение от fantom (??), 15-Сен-18, 20:17 
>>>> conf t
>>>> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
>>>> ip route 0.0.0.0 0.0.0.0 dhcp
>>>> end
>>>> copy run start
>>> +1
>> -1
>> ip route 0.0.0.0 0.0.0.0 FastEthernet4
> Садись, два. К следующему уроку выучить отличие Ethernet сетей от P-t-P подключений.

+1

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от ShyLion (ok), 17-Сен-18, 08:38 
> ip route 0.0.0.0 0.0.0.0 FastEthernet4

Очень весело выглядит ARP таблица потом на роутере, как и график загрузки CPU, после некоторого времени работы.

Так делать НЕЛЬЗЯ.

Оно иногда "работает" потому что у вышестоящего включен Proxy-arp, а у твоего роутера на каждый внешний IP создается ARP запись с маком провайдерского шлюза.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

6. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 15-Сен-18, 15:38 
>[оверквотинг удален]
>> !
>> ip forward-protocol nd
>> ip route 0.0.0.0 0.0.0.0 100.65.240.1
>> !
>> Подскажите, пожалуйста, я в тупик попал :(
> conf t
> no ip route 0.0.0.0 0.0.0.0 100.65.240.1
> ip route 0.0.0.0 0.0.0.0 dhcp
> end
> copy run start

Благодарю! В понедельник буду проверять

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

14. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Алекс (??), 20-Сен-18, 10:42 
слушайте,  а не думали спец обучение пройти? это бы помогло знания структурировать и тд
буквально на прошлой неделе закончил курс по маршрутизации в микротесте (это такой уч.центр), прям теперь брюсов Уэйном себя чувствую


Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

15. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 20-Сен-18, 11:39 
> слушайте,  а не думали спец обучение пройти? это бы помогло знания
> структурировать и тд
> буквально на прошлой неделе закончил курс по маршрутизации в микротесте (это такой
> уч.центр), прям теперь брюсов Уэйном себя чувствую

Прям таки на прошлой?

Короче, все заработало. Команда
ip route 0.0.0.0 0.0.0.0 dhcp творит чудеса :)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от fantom (??), 20-Сен-18, 12:47 
>> слушайте,  а не думали спец обучение пройти? это бы помогло знания
>> структурировать и тд
>> буквально на прошлой неделе закончил курс по маршрутизации в микротесте (это такой
>> уч.центр), прям теперь брюсов Уэйном себя чувствую
> Прям таки на прошлой?
> Короче, все заработало. Команда
> ip route 0.0.0.0 0.0.0.0 dhcp творит чудеса :)

Чудеса творит вдумчивое изучение документации :)
как там в классике:
"Учите матчасть!"

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 20-Сен-18, 13:20 
>>> слушайте,  а не думали спец обучение пройти? это бы помогло знания
>>> структурировать и тд
>>> буквально на прошлой неделе закончил курс по маршрутизации в микротесте (это такой
>>> уч.центр), прям теперь брюсов Уэйном себя чувствую
>> Прям таки на прошлой?
>> Короче, все заработало. Команда
>> ip route 0.0.0.0 0.0.0.0 dhcp творит чудеса :)
> Чудеса творит вдумчивое изучение документации :)
> как там в классике:
> "Учите матчасть!"

Ткните меня носом, с удовольствием прочитаю!

В интернете про динамические адреса нигде, кроме этого форума, нет. В книжке Дж. Бони Cisco IOS - тоже ничего нет. Что читать?

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Pofigist (?), 20-Сен-18, 21:05 
> Ткните меня носом, с удовольствием прочитаю!
> В интернете про динамические адреса нигде, кроме этого форума, нет. В книжке
> Дж. Бони Cisco IOS - тоже ничего нет. Что читать?

gw-01#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
gw-01(config)#ip route 0.0.0.0 0.0.0.0 ?
  A.B.C.D             Forwarding router's address
  ATM                 ATM interface
  Async               Async interface
  Auto-Template       Auto-Template interface
  BVI                 Bridge-Group Virtual Interface
  CDMA-Ix             CDMA Ix interface
  CTunnel             CTunnel interface
  DHCP                Default Gateway obtained from DHCP
  Dialer              Dialer interface
  GMPLS               MPLS interface
  GigabitEthernet     GigabitEthernet IEEE 802.3z
  Lex                 Lex interface
  LongReachEthernet   Long-Reach Ethernet interface
  Loopback            Loopback interface
  MFR                 Multilink Frame Relay bundle interface
  Multilink           Multilink-group interface
  Null                Null interface
  Port-channel        Ethernet Channel of interfaces
  Serial              Serial
  Tunnel              Tunnel interface
  Vif                 PGM Multicast Host interface
  Virtual-Dot11Radio  Virtual dot11 interface
  Virtual-PPP         Virtual PPP interface
  Virtual-TokenRing   Virtual TokenRing
  vmi                 Virtual Multipoint Interface

gw-01(config)#ip route 0.0.0.0 0.0.0.0

Внимательно смотрим на строчку "DHCP Default Gateway obtained from DHCP" - что тут непонятно?!
Вообще клавиши <Tab> и <?> в командной строке IOS творят чудеса... :)

Ну и таки да - надо понимать какой протокол ты настраиваешь... Ты не знаешь про DHCP? Изучаем - https://www.ietf.org/rfc/rfc2131.txt

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от uncle_grin (ok), 20-Сен-18, 21:11 
Спасибо!


Еще бы по-русски все это найти, так цены бы не было :)

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от Pofigist (?), 20-Сен-18, 22:42 
> Спасибо!
> Еще бы по-русски все это найти, так цены бы не было :)

Да НП... :)

По русски - искать по словам "Cisco Press на русском", переводилось очень много чего. Пошарься ну рутрекере например :)

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Как настроить WAN, если провайдер выдает динамический IP"  +/
Сообщение от fantom (??), 21-Сен-18, 10:47 
> Спасибо!
> Еще бы по-русски все это найти, так цены бы не было :)

Изобретаем машину времени, фигачим в 40-е, убеждаем Сталина, что кибернетика это суперважно и надо ее не секретить, а еще и империалистам продавать, в 60-х убеждаем не копировать чужое, а развивать свое и вуаля - весь мир хош/не_хош хреначит ПО на Великом и Могучем

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor