The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Решение проблем при работа нескольких ide-scsi устройств (ide scsi cdrom hardware)


<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>
Ключевые слова: ide, scsi, cdrom, hardware,  (найти похожие документы)
Date: Sat, 01 Mar 2003 10:08:43 +0500 From: Victor Wagner <vitus@45.free.net> Newsgroups: ftn.ru.linux Subject: Решение проблем при работа нескольких ide-scsi устройств OK> Имеются два девайса - cdrom (hdc) и dvd (hdd), OK> мне нужно, что бы dvd работал через эмуляцию scsi, OK> а cdrom как обычный ide-cd, хотя последнее не обязательно. OK> Ядро получает "hdd=ide-scsi", про hdc ничего не пишу, OK> в результате работать все может только в такой OK> последовательности - сначала монтирую hdc как ide-cd, OK> потом гружу ide-scsi и монтирую hdd. fstab такой: OK> ... OK> /dev/hdc /cdrom iso9660 ... OK> /dev/sr0 /dvd iso9660 ... OK> ... У меня это делается так: modprobe ide-mod modprobe ide-probe-mod modprobe ide-scsi В результате в /proc/scsi/scsi кроме дисков и сканера появляются: Host: scsi3 Channel: 00 Id: 00 Lun: 00 Vendor: TOSHIBA Model: DVD-ROM SD-R1202 Rev: 1026 Type: CD-ROM ANSI SCSI revision: 02 Host: scsi3 Channel: 00 Id: 01 Lun: 00 Vendor: ASUS Model: CD-S400/A Rev: 1.00 Type: CD-ROM ANSI SCSI revision: 02 После этого монтируется /dev/sr0 /dvd /dev/sr1 /cdrom Фишка состоит в том, чтобы до того, как загрузится ide-scsi отработал ide-probe-mod. иначе ide-scsi просто не увидит девайсов. Hасколько я понимаю, при попытке смонтировать /dev/hd* он отрабатывает автоматически.

<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>

Ваш комментарий
Имя:         
E-Mail:      
Заголовок:
Текст:





  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor