The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Перевод руководства по установке драйверов для ATI видеокарт. (video xfree86 x driver hardware)


<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>
Ключевые слова: video, xfree86, x, driver, hardware,  (найти похожие документы)
From: Мартынцев Александр <aleks@linux-online.ru> Date: Mon, 23 Feb 2004 14:31:37 +0000 (UTC) Subject: Перевод руководства по установке драйверов для ATI видеокарт. Оригинал: http://linuxshop.ru/unix4all/?cid=&id=434 Графические акселераторы: ATI Radeon 8500, 9100, 9200, 9500, 9600, 9700, 9800, ATI Mobility 9000, 9600 ATI FireGL 8700, 8800, E1, E2, X1, X2, Z1, T2 ATI Mobility FireGL T2 Видео-драйверы для Linux: Driver Version 4.1.0-3.7.0 Driver Version 4.2.0-3.7.0 Driver Version 4.3.0-3.7.0 Пожалуйста прочтите этот документ полностью. Информации из этого документа может не быть в документации или онлайн-справке. Этот READ-ME файл содержит следующую информацию: 1. Общая информация 1.1 Требования 1.2 Список за гружаемых файлов 2. Установка видео-драйвера 2.1 Определение нужного вам бинарного пакета 2.2 Установка драйвера с использованием rpm-менеджера 2.3 Создание ядра с поддержкой ISSE (Kernel 2.2.x) 2.4 Создание настроенного модуля ядра 2.5 Включение поддержки AGP 3. Конфигурация мониторов 3.1 Изменения в настройках монитора 4. Настройка и дополнительная информация 5. Использование программы CONTROL PANEL 5.1 Как запустить Control Panel Application 5.2 --- space --- 5.3 Гамма коррекция 6. Замечания и ограничения 7. Список поддерживаемых режимов 8. Сервис, поддержка и обновление софта 1. Общая информация ---------------------- Этот драйвер основан на версии xfree86 указанной в заголовке документа. (смотри http://www.xfree86.org/4.0/) Прежде чем устанавливать драйвер, вы должны установить эту версию xfree86. Если в вашем дистрибутиве Linux нету нужной версии XFree86, вам надо скачать и установить соответствующий бинарник xfree86 с ftp://ftp.xfree86.o rg/pub/XFree86/4.1.0/binaries/ или с ftp://ftp.xfree86.org/pub/XF ree86/4.2.0/binaries/ или с ftp://ftp.xfree86.org/pub/XFree86/4. 3.0/binaries/ 1.1 Требования * Для работы драйвера требуется любая Linux/x86 система в которой установлена glibc 2.2 (=libc 6.2). Если в вашей системе установлена glibc 2.3 то она будет также совместима с данными драйверами. * Должна быть установлена версия XFree86 - 4.1.0, 4.2.0 или 4.3.0 * Модуль OpenGL, идущий вместе с драйвером, может использовать расширенный набор команд ISSE вашего x86-процессора. Поэтому ваше ядро должно быть сконфигурировано с поддержкой этих инструкций. (ISSE: Internet Streaming Single-Instruction, Multiple-Data Extensions; расширение инструкций IA-32, есть в процессорах Intel Pentium III, Intel Pentium 4 и с недавних пор в процессорах AMD Athlon.) Современные версии дистрибутивов Linux уже содержат поддержку ISSE и содержат i686-оптимизированную версию ядра 2.4.xx. Вы можете добавить поддержку ISSE в ядро Linux, выполнив следующие действия: * установив патч для ядра (см. пункт 2.3) * пересобрав ядро * установив пересобранное ядро Примечание: Драйвер OpenGL может использовать инструкции AMD 3DNow! и ядро в данном случае не нуждается ни в каких патчах для их использования. * Чтобы вы могли создавать свои собственные загружаемые модули для ядра, вам нужно иметь полное древо настроек исходников ядра на своем компьютере 1.2 Список загружаемых файлов fileinfo.txt - Быстрое руководство по установке. Check.sh - Скрипт для определения версии libc и XFree86. readme.txt - Этот документ. fglrx-glc22-4.1.0-3.7.0.i386.rpm - Драйвер для x86 систем с libc6.2 (=glibc2.2) и XFree86 4.1.0 в rpm формате. fglrx-glc22-4.2.0-3.7.0.i386.rpm - Драйвер для x86 систем с libc6.2 (=glibc2.2) и XFree86 4.2.0 в rpm формате. fglrx-glc22-4.3.0-3.6.0.i386.rpm - Драйвер для x86 систем с libc6.2 (=glibc2.2) и XFree86 4.3.0 в rpm формате. 2. Установка видеодрайвера 2.1 Определение нужного вам бинарного пакета Определите, какой бинарник нужен для вашей системы. Для этого загрузите скрипты 'Install.sh' или 'Check.sh' и запустите их: sh Install.sh -check или sh Check.sh Это позволит вам узнать нужную версию бинарника. 2.2 Установка драйвера с использованием rpm-менеджера Скопируйте нужный rpm-пакет во временную папку, в которой вы сможете создавать, удалять и модифицировать файлы и каталоги. Вам потребуется около 5 MB дискового пространства. Получите привилегии супер-пользователя (root) и перейдите (cd) в директорию с пакетом. Запустите rpm-менеджер командой: rpm -Uhv .rpm В случае, если у вас появились какие-то проблемы, дайте такую команду: rpm -i --force .rpm Т.к. rpm-менеджер при установке проверяет зависимости пакетов, то он может выдать имена библиотек или пакетов, которые нужны для нормальной работы драйвера. Вы можете указать опцию отмены проверки зависимостей "--nodeps" (подробнее о этой опции читайте в манах RPM), но вообще это весьма не желательно. Например может появиться сообщение о необходимости установки QT 2.x.x, для нормальной работы с драйвером. В этом случае вы должны установить требуемую версию QT и повторить установку драйвера. Если у вас нет или вы не хотите устанавливать требуемую версию библиотеки QT, вы можете при установке указать опцию "--nodeps". Т.к. библиотека QT требуется только для FGL-панелей, то эти панели, при игнорировании этой зависимости, могут не запускаться. Примечание для пользователей RedHat 8.0: При инсталляции RedHat 8.0 часто устанавливаются специфические версии libGL. (Например XFree86-Mesa-libGL-4.2.0-72). Устанавливаемые драйверы ATI Linux вступит с ними в конфликт, т.к. они содержат свою специальную версию libGL, обеспечивающую дополнительную поддержку extra pbuffer. Инсталлируя драйвер ATI необходимо либо заменить существующую версию libGL либо удалить е╠: * Используя опцию --force RPM-менеджера можно заменить старую libGL: rpm -i --force .rpm или * Можно удалить старую версию libGL и установить новую из пакета с драйверами ATI. Например так: rpm -e --nodeps XFree86-Mesa-libGL-4.2.0-72 rpm -Uhv .rpm Примечание: (1) ВНИМАНИЕ! В процессе установки не должна выполняться ни одна программа использующая OpenGL (2) При инсталляции надо использовать опцию "--nodeps", потому как скринсейверы, qt-3 и другие части XFree86 могут зависеть от libGL. После установки драйвера выполните следующие шаги: * Запустите fglrxconfig для настройки XFree86. * Ответьте на вопросы программы. * Сохраните установки в /etc/X11/XF86Config-4. Некоторые замечания для пользователей debian: В дистрибутиве debian Linux обычно не включены средства для работы с rpm-пакетами. Но в нем существует утилита "alien", которая конвертирует rpm-файлы в поддерживаемый debian'ом формат *.deb . Например: dpkg -i .deb Чтобы игнорировать сообщения (которые могут появиться из-за установленного пакета "xlibmesa3") используйте такую команду: dpkg -i --force-overwrite .deb 2.3 Создание ядра с поддержкой ISSE (Kernel 2.2.x) Примечание: Вы можете пропустить информацию из этого раздела если: (1) У вас Kernel 2.4.xx: Kernel 2.4.xx и современные дистрибутивы идут со встроенной поддержкой ISSE. (2) Ваш CPU не имеет поддержки ISSE. Если ваше ядро не имеет поддержки инструкций Pentium III ISSE, вам нужно пропатчить ядро для возможности их использования. Патч находится по адресу http://people.redhat.com/mingo/mmx-patches/ Пожалуйста, заметьте, что эти патчи имеют стадии 'alpha' или 'beta'. Версия "mmx-2.2.14-A0" была нами проверена и показала не плохой результат. Вы должны использовать "первозданное" ядро с www.kernel.org. Ядра дистрибутивно-специфичные, например 2.2.14-5.0 для RedHat или 2.2.14.SuSE могут не работать с патчем. +++ Настоятельно рекомендуем сохранить старые исходники ядра, перед установкой патча! +++ Извлеките исходники ядра в какую-нибудь директорию, обычно в /usr/src. Убедитесь, что новые исходники ядра имеют символическую ссылку на /usr/src/linux. Скопируйте патч в /usr/src и распакуйте его: * для gzip-упакованного патча используйте 'zcat piii.gz | patch -p0 -E' * для не упакованного патча 'cat piii | patch -p0 -E' Если ни каких сообщений об ошибках не будет выдано, значит ваше ядро и патч нормально совместимы и патч успешно установился. Перейдите в '/usr/src/linux' и дайте команду 'make menuconfig' для запуска программы конфигурации ядра. Войдите в раздел "Processor type and features". Выбирете "PIII/Xeon/Deschutes". Для полностью рабочего, ISSE-совместимого ядра выбирете следующие опции: - Processor type and features (PIII/Xeon/Deschutes) Processor Family - [*] Enable CPU Specific (MMX/MMX2) Optimization Functions - [*] MTRR (Memory Type Range Register) support - Loadable Module Support - [*] Enable loadable module support - [*] Kernel module loader support Сохраните настройки и выйдите из программы конфигурации. Соберите свое ядро, согласно документации вашего дистрибутива. Установите новое ядро и протестируйте его. В случае возникновения проблем проверьте файлы /var/log/XFree86.0.log и /var/log/messages для выяснения их причин. 2.4 Создание загружаемого модуля ядра FireGL 8700/8800 довольно интенсивно использует возможности вашего компьютера. Специально настроенный подгружаемый модуль ядра необходим для поддержки некоторых особенностей, например поддержки AGP, busmaster DMA или управления памятью. Такой модуль будет загружаться во время загрузки системы или когда будет запускаться x-server и все время будет оставаться загруженным и доступным . Примечание: Если модуль будет отсутствовать, то у вас не будет работать аппаратное 3D-ускорение и 2D драйвер может выдавать ошибки при загрузке. Вам нужно запустить ручную компоновку модуля ядра * если у вас нету поддержки аппаратного 3D (для проверки запустите fglrxinfo) * если в системе произошли какие-нибудь глобальные изменения, например вы сменили ядро * если у вас были проблемы с установкой драйвера Бинарный пакет обеспечивает полностью рабочие модули ядра для некоторых дистрибутивов и версий ядра. В некоторых случаях вы не должны формировать модуль ядра самостоятельно. Инсталлятор сообщит вам об успешной инсталляции модуля. Ручное создание модуля необходимо например при установке нового ядра. В этом случае вам необходимо настроить исходники вашего ядра в/usr/src/linux. Для формирования модуля вам необходимо иметь права администратора. Вам необходимо будет запустить два скрипта, которые и сформируют модуль. Выполните следующие шаги: * перейдите в каталог с исходниками ядра * запустите "make distclean" * установите исходники ядра с нужным вам конфигурационным файлом * запустите "make dep" * перейдите в "/lib/module/fglrx/build_mod" и выполните команду "./make.sh" * перейдите в "/lib/module/fglrx" и введите "./make_install.sh" Перейдите в каталог /lib/module/fglrx/build_mod и выполните команду "./make.sh". Таким образом вы создадите новый модуль ядра. Если при создании произошли ошибки, то их причину надо искать в оболочке и файле "make.log". Примечания: Игнорируйте следующие предупреждения, которые могут появиться в некоторых дистрибутивах: compiling... /tmp/ccOWu6AI.s: Assembler messages: /tmp/ccOWu6AI.s:9: Warning: Ignoring changed section attributes for .modinfo Определенная комбинация исходников ядра Linux и компилятора C может вызвать это предупреждение. Обычно такие сообщения появляются, если вы сами вручную формировали ядро. Для установки модуля ядра требуется наличие заголовочных файлов вашего ядра Linux. Если ваше ядро получено из дистрибутива: * Получите исходники из RPM-файла * Извлеките файлы настроек хранящиеся там. (в RedHat Linux файлы находятся в поддиректории "configs". для SuSE Linux: ищите файлы в SRPM. Установите ваше ядро с этими настройками: * скопируйте файлы конфигурации в /usr/src/linux/.config * запустите "make oldconfig" для импорта Запустите "make dependencies" ("make dep"). Примечание: Если вы хотите сформировать несколько модулей для разных конфигурация ядра, запускайте "make distclean" после каждого цикла установки. Если вы не смогли сформировать заголовочные файлы ядра * сформируйте новое ядро с оптимальными для вашей машины настройками * установите его и загрузите * перейдите к разделу установки. Выполните завершающий шаг: * перейдите в /lib/modules/fglrx * запустите ./make_install.sh Это скопирует ваш новый модуль в нужные директории. Скрипт также обновит список подгружаемых модулей. 2.5 Включение поддержки AGP Некоторые современные дистрибутивы, например SuSE 7.0 или RedHat 7.0, идут с включенной поддержкой AGP. За нее отвечает модуль ядра 'agpgart'. Поверить загружен или нет AGP-модуль можно командой 'lsmod' под root'ом. С запущенным XServer и установленной связью, индекс модуля agpgart должен отличаться от нуля. Примечание: При установке fglrx и проверки зависимостей, модуль 'agpgart' не требуется как обязательно присутствующий. Если в вашей системе не установлен этот модуль, то драйвер fglrx будет использовать свой. 3. Конфигурация мониторов Примечание: * Полные оверлейные функциональные возможности доступны только в режиме Single Head. * Подсоединенный цифровой дисплей - всегда первичный. * Primary/Secondary head доступны, если подключены два монитора Quad Buffer Stereo ("Active Stereo") доступен только в режиме Single Head. * Primary Head: нижний DVI-порт на X1, LCD-выход на M9, только DVI-порт на других картах (Монитору подключенному к этой голове соответствует первая строка в опциях MonitorLayout). * Secondary Head: верхний DVI-порт на X1, VGA порт на всех других видеокартах (Монитору подключенному к этой голове соответствует вторая строка в опциях MonitorLayout). Драйвер поддерживает следующую конфигурацию мониторов. * Single Head: Работает только один монитор. Если подключен второй, то он показывает черный экран. Это единственный доступный режим, если у вас подключен только один монитор. Только в этом режиме работает режим Quad Buffer Stereo ("Active Stereo"). * Clone: Содержимое первичного монитора отображается на вторичном. Если один из мониторов не может работать в выбранном разрешении экрана, то для этого монитора автоматически выбирается более низкое разрешение. * Big Desktop. Есть один большой фреймбуер разбитый горизонтально или вертикально на две части и каждая из частей отображается на свой монитор. Доступные подрежимы: * Big Desktop Horizontal: расположение мониторов горизонатльное. Левый монитор - первичный, правый - вторичный. * * Big Desktop Vertical: расположение мониторов вертикальное. Верхний монитор - первичный, нижний - вторичный. Примечания: Всего имеется только один фреймбуфер и только один оконный менеджеры. Оба монитора должны работать с одинаковыми настройками видео режима. Информация о режимах в 'Section Screen, Subsection Display, Modes' (в XF86Config-4) относится к обоим мониторам. Максимальное разрешение для OpenGL: * семейство R200 (Radeon 8500-9000 Pro, Fire GL 8700/8800/E1): 2048x2048 * семейство R300 (Radeon 9500-9700 Pro, Fire GL X1/Z1): 2560x2560 Опция "ScreenOverlap" (тип OPTV_INTEGER): * Эта опция предназначена для накладывания двух изображений, например с двух видео-проекторов. * Эта опция применима только для режима "Big Desktop" * Значение опции определяет ширину прямоугольной области. * Результатирующая виртуальная ширина экрана (если виртуальный экран не был определен) получается суммированием ширины двух экранов минус полученное overlap-значение. * Настройки мониторов остаются неизменными Dual Head: Отдельный фреймбуфер, независимые видеорежимы для каждого из мониторов (возможны два оконных менеджера). 3.1 Изменение настроек монитора ВАЖНО: Изменяйте файл XF86Config-4, только используя утилиту fglrxconfig. Примечание: Чтобы настраивать файл XF86Config-4 вы должны знать тип своего монитора, клавиатуры и мышки. Смотрите первоначальный конфигурационный файл. Предупреждение: Не задавайте режимы работы монитора, которые им не поддерживаются. Неправильные настройки монитора могут его повредить! Изменить настройки монитора можно выполнив следующие шаги: * Получите root-привилегии. * Запустите программу настройки FireGL 8700/8800/E1/X1/Z1, введя команду: fglrxconfig * Ответьте на вопросы программы и сохраните настройки в в /etc/X11/XF86Config-4. * Перезапустите XServer. 4. Настройка и дополнительная информация * Проверить работоспособность 3D-акселерации можно используя программу 'fglrxinfo', которая входит в комплект поставки драйвера FireGL 8700/8800. Запустите тестовую программу набрав команду: fglrxinfo Типичная выводимая информация (при нормальной работе 3D-ускорения) может быть такой: OpenGL vendor string: ATI OpenGL renderer string: FireGL 8700/8800 OpenGL version string: 1.2.1234 (1.2.3) * Некоторые утилиты, например из группы XFree86 могут также могут предоставлять дополнительную информация, например xdpyinfo или glxinfo. * Для информации о поддержке CPU на вашей системе, запустите программу "cpu_check". (Эта программа может присутствовать только если вы установили FireGL 1 - 4 драйверы.) * Dual Head Configuration Драйвер поддерживает мультизагрузку, т.е. два экрана могут иметь различные оконные менеджеры. Используйте утилиту "fglrxconfig" для включения режима dual head. Получить контроль над вторым экраном можно переместив в него мышь. Примечание: Xinerama и DRI являются взаимоисключающими. Из-за этого Xinerama не должна быть включена. * Video Overlay Все видео карты поддерживаемые этим драйвером могут работать в режиме Video Overlay. Этот режим вы сможете указать при работе с утилитой fglrxconfig. Примечания: -Video Overlay, OpenGL Overlay и Quad Buffer Stereo ("Active Stereo") являются взаимоисключающими режимами. * Quad Buffer Stereo ("Active Stereo") FireGL X1 поддерживает режим Quad Buffer Stereo ("Active Stereo". Включение режима Stereo осуществляется путем добавления строки 'Option "Stereo" "on"' в файл XF86Config-4 и отключением режимов VideoOverlay и OpenGLOverlay. Используйте по крайней мере 100 Hz (лучше 120Hz) режимы для Stereo. Примечание: Для стереоскопического изображения вам нужны специальные очки, которые не входят в комплект поставки. Их подключают к разъемам на видеокарте и для каждого глаза выводится свое собственное изображение * Full Scene Anti Aliasing (FSAA) FireGL X1 использует технологию мультисемплинга вместе с антиалайзингом. Установить/включить/отключить FSAA можно используя Опцию "FSAAScale" (тип OPTV_INTEGER). Возможные значения "FSAAScale": + "1" (отключение FSAA) + "2" (2 multi sample points) + "4" (4 multi sample points) + "6" (6 multi sample points). Примечание: + По умолчанию FSAA установлена в "2.2." (обычная для CRT-мониторов). Отключить FSAA (т.е. установить в 1.0") можно используя 'Option "FSAADisableGamma" "yes"' (тип OPTV_BOOLEAN) + Если вы вручную хотите установить размеры семплов задайте опцию 'Option "FSAACustomizeMSPos" "yes"' (тип OPTV_BOOLEAN) + Установите ... o ... для первой точки Option "FSAAMSPosX0" (тип OPTV_DOUBLE) Option "FSAAMSPosY0" (тип OPTV_DOUBLE) o ... для второй точки Option "FSAAMSPosX1" (тип OPTV_DOUBLE) Option "FSAAMSPosY1" (тип OPTV_DOUBLE) o ... для третьей точки Option "FSAAMSPosX2" (тип OPTV_DOUBLE) Option "FSAAMSPosY2" (тип OPTV_DOUBLE) o ... для четвертой точки Option "FSAAMSPosX3" (тип OPTV_DOUBLE) Option "FSAAMSPosY3" (тип OPTV_DOUBLE) o ... для пятой точки Option "FSAAMSPosX4" (тип OPTV_DOUBLE) Option "FSAAMSPosY4" (тип OPTV_DOUBLE) o ... для шестой точки Option "FSAAMSPosX5" (тип OPTV_DOUBLE) Option "FSAAMSPosY5" (тип OPTV_DOUBLE) o Для FSAA "2" устанавливаются 2 точки, для FSAA "4" устанавливаются 4 точки для FSAA "6" устанавливаются все 6 точек. + Диапазон. Размер пикселей 1x1, диапазон составляет (0 <= (X position) <= 1) и (0 <= (Y position) <= 1). + (FSAA работает только в OpenGL. 5. Использование программы CONTROL PANEL Текущие драйверы поставляются с удобными в работе панелями управления, интегрированными в оконные менеджеры. Благодаря им, вы сможете быстро отыскать информацию о адаптере и его настройках, а также установить нужные вам режимы экрана и подстроить гамму. Примечание: Код панели основан на QT Toolkit для Linux от Trolltech. По этому не все платформы Linux могут иметь в своем составе нужные библиотеки, но мы поставляем панель в двух версиях: * статически связанной и * динамически связанной По умолчанию используется динамически связанная версия. Если в вашей системе отсутствуют нужные библиотеки QT тогда инсталлятор будет использовать статическую версию панели, которая будет доступна в: /usr/X11R6/bin/fireglcontrol .static Этот бинарник содержит нужные библиотеки QT внутри. Эта версия панели занимает больше места и использует больше памяти. Неиспользованная версия панели будет также присутствовать в вашей системе, но в сжатом виде. Она будет находиться в каталоге /usr/X11R6/bin Примечание: Пользователям RedHat 8.0 для нормальной работы панели нужно установить пакет qt-devel. 5.1 Как запустить Control Panel Application Запуск панели управления: * Если у вас RedHat 8.0 тогда идите в: Main Menu => Extras => Other => ATI Control * Если у вам GNOME Desktop Environment тогда идите в: Main Menu => Programs => ATI Control * Если вы пользуетесь KDE Desktop Environment идите в: Main Menu ("K icon") => ATI Control * Если вы пользуетесь другим оконным менеджером, ищите FireGL 8700/8800 control panel в: /usr/X11R6/bin/fireglcontrol * Если вы нашли каталог с приложением панели дайте команду fireglcontrol для ее запуска. 5.3 Гамма-коррекция Настройки гамма-коррекции индивидуальны для каждого монитора * В панели управления ATI FireGL 8700/8800 выберите нужный тег монитора для которого вы хотите настройть гамму-коррекцию: + Monitor tab 1 если монитор подключен к VGA-разъему + Monitor tab 2 если монитор подключен к DVI-разъему. * выбирете закладку Adjustment для желаемого монитора Настройте гамма-коррекцию монитора путем перемещения ползунков соответствующих цветов - красного, синего и зеленого. Внесенные изменения тут же отобразятся на соответствующем мониторе. Диапазон перемещения ползунков - 0.1 - 10.0 (по X). По умолчанию стоит 1.0. С выбранной опцией "Link sliders" три ползунка перемещаются одновременно при движении любого из них. С отключенной опцией "Link sliders", вы можете корректировать каждый из цветов в отдельности. Щелкните на кнопку "1", если хотите установить значение коррекции цветов по умолчанию. Нажмите кнопку Apply ил OK для применения изменений. 6. Замечания и ограничения * Для системы SuSE с XFree86 4 и выше можно сделать следующее: Если вы получаете предупреждения по поводу неполной или отсутствующей поддержке GLX при запуске любого opengl приложения (или скрипта 3Ddiag) то вам необходимо выполнить такие действия: Установить на вашу машину пакет xf86_glx-4.*.i386.rpm. Если вы выбрали "3D hardware support" во время инсталляции системы, то возможно этот пакет уже установлен. После этого надо выполнить два сценария /usr/X11R6/bin/switch2xf86-4 /usr/X11R6/bin/switch2xf86_glx которые установят исполняемые файлы X4.x.x. * Ограничения + Системы с libc 6.0 или libc 6.1 не поддерживаются. + Панорамирование/скроллинг не работают в режиме "big desktop" * Для информации по программированию OpenGL Applications, DRI, DRM читайте файл README.DRI находящийся в /usr/X11R6/lib/X11/doc. * Другие исполнения OpenGL + Ваша система может быть установлена с другими OpenGL-совместимыми библиотеками (например MesaGL) у которых более высокий приоритет, чем у аппаратно поддерживаемых библиотек. + Ваши программы могут использовать другие GL библиотеки, нежели FireGL 8700/8800 - и в результате не иметь аппаратной поддержки 3D-ускорения. В результате ваши приложения могут исполняться медленнее, чем если бы они использовали библиотеки FireGL 8700/8800. В этом случае вам необходимо проконсультироваться у Unix/Linux эксперта, который поможет вам перекомпилировать приложения так, чтобы они использовали нормальные библиотеки. Чтобы узнать какие библиотеки использует программа, введите команду ldd * DRI и безопасность Раздел "dri" в вашем XF86Config-4 может быть например таким: Section "DRI" Group "video" Mode 0660 EndSection Это означает, что только пользователи группы "video" могут использовать аппаратное 3D-ускорение. Чтобы добавить пользователя в группу "video", необходимо: + открыть в редакторе /etc/group, + найти "video" + добавить нового пользователя(ей) в конец строки 'video', разделяя имена запятой Пример: добавим пользователя 'henryc' к video:x:33:frankh,michaelg в результате получим video:x:33:frankh,michaelg,henryc * Использование расширенных библиотек OpenGL (GLU, GLUT) В поставку некоторых дистрибутивов входят расширенные библиотеки OpenGL. Некоторые приложения могут потребовать библиотеки, которые не установлены в вашей системе. Большинство библиотек взаимозаменяемы - (libMesaGLU.??? -> libGLU.so, libMesaGLUT -> libGLUT). Для большинства приложения можно сделать следующее: + создать ссылку на внешнюю библиотеку с требуемым именем ln -s + запустить 'ldconfig'. 7. Список поддерживаемых режимов Следующий список содержит небольшое количество проверенных режимов для графических плат FireGL X1/Z1/X2. Из-за ограничений вашего монитора не все режимы могут быть для вас доступны. Для установки режима "Big Desktop" запустите утилиту "fglrxconfig". ......... 8. Сервис, поддержка и обновление софта Новые версии видеодрайвера можно получить на: http://www.ati.com ---------------------------------------------------------------------- Все названия продуктов упомянутых в этом тексте защищены авторским правом. ---------------------------------------------------------------------- (c) Copyright 2002,2003 by ATI Technologies Inc. All rights reserved ---------------------------------------------------------------------- Перевод и обработка: Мартынцев Александр. <aleks@linux-online.ru> © 2000 - 2003 ООО "Линукс-Онлайн"

<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>

Обсуждение [ RSS ]
 
  • 1, Александр Мартынцев, 12:32, 04/01/2005 [ответить] [смотреть все]
  • +/
    Рекомендую сменить мой e-mail с aleks@linux-online.ru на aleks@linuxtoday.ru
     
  • 2, Антон, 23:22, 01/07/2005 [ответить] [смотреть все]
  • +/
    Вы не подскажите подайдет ли дравер OpenGL на видиокарту NVIDIA GeForce 2 MX\MX 400 и где ее можно найти?
     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:





      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor